Bug 969152 - [abrt] libvirt-daemon-0.10.2.4-1.fc18: vasprintf: Process /usr/sbin/libvirtd was killed by signal 11 (SIGSEGV)
[abrt] libvirt-daemon-0.10.2.4-1.fc18: vasprintf: Process /usr/sbin/libvirtd ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ján Tomko
Fedora Extras Quality Assurance
abrt_hash:3a33c9db59e4cbfcca53fef9711...
:
Depends On:
Blocks: 971904
  Show dependency treegraph
 
Reported: 2013-05-30 15:20 EDT by Ivan Makfinsky
Modified: 2013-08-14 22:54 EDT (History)
10 users (show)

See Also:
Fixed In Version: libvirt-0.10.2.7-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 971904 (view as bug list)
Environment:
Last Closed: 2013-08-14 22:54:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (278.97 KB, text/plain)
2013-05-30 15:21 EDT, Ivan Makfinsky
no flags Details
File: cgroup (162 bytes, text/plain)
2013-05-30 15:21 EDT, Ivan Makfinsky
no flags Details
File: core_backtrace (1.63 KB, text/plain)
2013-05-30 15:21 EDT, Ivan Makfinsky
no flags Details
File: dso_list (9.85 KB, text/plain)
2013-05-30 15:21 EDT, Ivan Makfinsky
no flags Details
File: environ (114 bytes, text/plain)
2013-05-30 15:21 EDT, Ivan Makfinsky
no flags Details
File: limits (1.29 KB, text/plain)
2013-05-30 15:21 EDT, Ivan Makfinsky
no flags Details
File: maps (47.36 KB, text/plain)
2013-05-30 15:21 EDT, Ivan Makfinsky
no flags Details
File: open_fds (658 bytes, text/plain)
2013-05-30 15:21 EDT, Ivan Makfinsky
no flags Details
File: proc_pid_status (899 bytes, text/plain)
2013-05-30 15:21 EDT, Ivan Makfinsky
no flags Details
File: var_log_messages (17.70 KB, text/plain)
2013-05-30 15:22 EDT, Ivan Makfinsky
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 968930 None None None Never

  None (edit)
Description Ivan Makfinsky 2013-05-30 15:20:53 EDT
Version-Release number of selected component:
libvirt-daemon-0.10.2.4-1.fc18

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/sbin/libvirtd
crash_function: vasprintf
executable:     /usr/sbin/libvirtd
kernel:         3.9.4-200.fc18.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 vasprintf at /usr/include/bits/stdio2.h:210
 #3 virVasprintf at util/util.c:1984
 #4 virLogVMessage at util/logging.c:723
 #5 virLogMessage at util/logging.c:670
 #6 udev_log at src/libudev/libudev.c:64
 #7 udev_device_new_from_syspath at src/libudev/libudev-device.c:726
 #8 udevProcessDeviceListEntry at node_device/node_device_udev.c:1353
 #9 udevEnumerateDevices at node_device/node_device_udev.c:1386
 #10 udevDeviceMonitorStartup at node_device/node_device_udev.c:1704
 #11 virStateInitialize at libvirt.c:804
Comment 1 Ivan Makfinsky 2013-05-30 15:21:01 EDT
Created attachment 755017 [details]
File: backtrace
Comment 2 Ivan Makfinsky 2013-05-30 15:21:07 EDT
Created attachment 755018 [details]
File: cgroup
Comment 3 Ivan Makfinsky 2013-05-30 15:21:12 EDT
Created attachment 755019 [details]
File: core_backtrace
Comment 4 Ivan Makfinsky 2013-05-30 15:21:19 EDT
Created attachment 755020 [details]
File: dso_list
Comment 5 Ivan Makfinsky 2013-05-30 15:21:26 EDT
Created attachment 755021 [details]
File: environ
Comment 6 Ivan Makfinsky 2013-05-30 15:21:32 EDT
Created attachment 755022 [details]
File: limits
Comment 7 Ivan Makfinsky 2013-05-30 15:21:40 EDT
Created attachment 755023 [details]
File: maps
Comment 8 Ivan Makfinsky 2013-05-30 15:21:47 EDT
Created attachment 755024 [details]
File: open_fds
Comment 9 Ivan Makfinsky 2013-05-30 15:21:57 EDT
Created attachment 755025 [details]
File: proc_pid_status
Comment 10 Ivan Makfinsky 2013-05-30 15:22:04 EDT
Created attachment 755026 [details]
File: var_log_messages
Comment 11 Ivan Makfinsky 2013-06-06 19:17:05 EDT
Apparently I had udev_log="debug" in /etc/udev/udev.conf.

I set the log to info and libvirtd service starts up normally.

I found the solution here:

https://bugs.launchpad.net/ubuntu/+source/libvirt/+bug/968930

It shouldn't crash just because udev is logging debug messages.
Comment 12 Ján Tomko 2013-06-07 09:48:10 EDT
Upstream patch proposed:
https://www.redhat.com/archives/libvir-list/2013-June/msg00349.html
Comment 13 Ján Tomko 2013-06-14 08:28:32 EDT
Now fixed upstream:
commit f753dd62f951cc62e164421d0c6491f39e4c68ad
Author:     Ján Tomko <jtomko@redhat.com>
AuthorDate: 2013-06-07 11:55:27 +0200
Commit:     Ján Tomko <jtomko@redhat.com>
CommitDate: 2013-06-14 13:17:27 +0200

    udev: fix crash in libudev logging
    
    Call virLogVMessage instead of virLogMessage, since libudev
    called us with a va_list object, not a list of arguments.
    
    Honor message priority and strip the trailing newline.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=969152

git describe: v1.0.6-76-gf753dd6
Comment 14 Fedora Update System 2013-08-01 19:50:46 EDT
libvirt-0.10.2.7-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libvirt-0.10.2.7-1.fc18
Comment 15 Fedora Update System 2013-08-02 17:48:25 EDT
Package libvirt-0.10.2.7-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libvirt-0.10.2.7-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14066/libvirt-0.10.2.7-1.fc18
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2013-08-14 22:54:56 EDT
libvirt-0.10.2.7-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.