Bug 969183 - RHEL 6 boost not compatible with DTS gcc
Summary: RHEL 6 boost not compatible with DTS gcc
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: boost
Version: 6.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Petr Machata
QA Contact: Miroslav Franc
URL:
Whiteboard:
Depends On:
Blocks: 1056252
TreeView+ depends on / blocked
 
Reported: 2013-05-30 20:28 UTC by Petr Machata
Modified: 2016-02-01 02:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 06:22:21 UTC
Target Upstream Version:


Attachments (Terms of Use)
Fix for this issue (631 bytes, patch)
2013-05-30 20:28 UTC, Petr Machata
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1440 normal SHIPPED_LIVE boost bug fix and enhancement update 2014-10-14 01:05:56 UTC

Description Petr Machata 2013-05-30 20:28:10 UTC
Created attachment 755041 [details]
Fix for this issue

Description of problem:
Boost as shipped with RHEL 6 fails to detect threading support in recent GCC's (such as those shipped with DTS).  See this for more details:
  https://svn.boost.org/trac/boost/ticket/6165

Version-Release number of selected component (if applicable):
boost-1.41.0-18.el6

How reproducible:
Always.

Steps to Reproduce:
1. Attempt to build boost with recent (post-4.7) GCC.
-or-
2. Compile the following program against recent Boost headers:

Actual results:
Failure:
#include <boost/thread.hpp>
In file included from ./boost/thread/detail/platform.hpp:17:0,
                 from ./boost/thread/thread.hpp:12,
                 from ./boost/thread.hpp:13,
                 from ../x.cc:1:
./boost/config/requires_threads.hpp:29:4: ошибка: #error "Threading support unavaliable: it has been explicitly disabled with BOOST_DISABLE_THREADS"

Expected results:
Success.

Comment 3 errata-xmlrpc 2014-10-14 06:22:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1440.html


Note You need to log in before you can comment on or make changes to this bug.