Bug 969195 - Cryptic NullPointerExceptions in XATTR Classes
Cryptic NullPointerExceptions in XATTR Classes
Status: CLOSED DUPLICATE of bug 996297
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhs-hadoop (Show other bugs)
2.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Bradley Childs
hcfs-gluster-bugs
:
Depends On: 970183 965266 968432 974241 1052748 1056652 1084239
Blocks: 969223
  Show dependency treegraph
 
Reported: 2013-05-30 17:20 EDT by Jay Vyas
Modified: 2014-04-03 21:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 968432
: 969223 (view as bug list)
Environment:
Last Closed: 2013-08-20 12:07:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Jay Vyas 2013-05-31 20:51:40 EDT
There is a possibility that this bug only has one cause - and that both source experiencing it in the stacktrace in fact reached it via the similarly bad configurations.  

But in any case, a better error message is required.  NullPointerExcptions should only occur if a field is null for unknown reasons - in this case - we know that the field is null because the system is not able to access xattrs.
Comment 3 Bradley Childs 2013-08-20 12:07:47 EDT

*** This bug has been marked as a duplicate of bug 996297 ***

Note You need to log in before you can comment on or make changes to this bug.