Bug 969279 - successful running of application may depend on name of the jnlp file
successful running of application may depend on name of the jnlp file
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: icedtea-web (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: jiri vanek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-31 02:44 EDT by jiri vanek
Modified: 2013-06-28 07:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-28 07:47:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jiri vanek 2013-05-31 02:44:14 EDT
Description of problem:
As icedtea-web do comparison between filename and name included inside this jnlp file, and in case that they differ it re-download it. In some cases this can not be possible - eg the jnlp file was downloaded from url with session id.


Version-Release number of selected component (if applicable):
all icedtea-webs 1.0 - head

How reproducible:
Good example is ellumintae. When you download jnlp file firstime, it is running fine. When you (accidentally) cancel it and/or download it again, that browser will mostly save it as livesession_1_.jnlp or similar instead of livesession.jnlp.


Actual results:
Icedtea-web then  will try to re-download livesession.jnlp, where its fail, because jnlp is generated and bounded with session id.
(in case of replicating this, be patient, it downloads many jars and tsrat of first one can take time...)

Expected results:
- icedtea web can probably work without using the filename, just using the name inside jnlp. Or at least do this when can not redownload jnlp file
- close this as wont fix - security hardening


possible workaround is to be more careful when running elluminate - eg use save as and javaws command instead of "open with" (which leads to some tmp name) and be sure final destination do not have same_name already inside (willl lead to some random suffix)

Note You need to log in before you can comment on or make changes to this bug.