Bug 969346 - @ServerSetup tasks throw RE, this makes other tests fail
@ServerSetup tasks throw RE, this makes other tests fail
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Testsuite (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: EAP 6.1.1
Assigned To: baranowb
:
: 967533 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-31 05:27 EDT by baranowb
Modified: 2013-09-16 16:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 16:28:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-1439 Minor Resolved ServerSetupObserver leaks changes if exception is thrown 2016-11-05 07:17 EDT

  None (edit)
Description baranowb 2013-05-31 05:27:57 EDT
Possibly.
Description of problem:
If @ServerSetup throws RE, ServerSetupObserver clears setup tasks list, essentially renders testsuite broken. This is because observers removes all tasks, hence, when cleanup happens( Arq events ) ServerSetupObserver does not invoke any setup tasks to cleanup container.

Version-Release number of selected component (if applicable):


How reproducible:
Throw RE from setup task. See other tests fail.

Actual results:
~50 failures

Expected results:
Clean run despinte one failure.

Additional info:

This needs a bit of investigation, as expected fix... does not fix the problem, it makes it even worse.
Comment 1 Rostislav Svoboda 2013-06-07 06:17:00 EDT
QA_ACK granted, AS TS fix.
Comment 5 baranowb 2013-06-21 00:24:54 EDT
*** Bug 967533 has been marked as a duplicate of this bug. ***
Comment 6 Pavel Jelinek 2013-07-15 07:50:55 EDT
Fixed in 6.1.1.ER2

Note You need to log in before you can comment on or make changes to this bug.