Bug 969405 - Spice shared clipboard is not working in anaconda DVD.iso
Spice shared clipboard is not working in anaconda DVD.iso
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-31 07:26 EDT by Vojtěch Boček
Modified: 2014-01-30 17:11 EST (History)
11 users (show)

See Also:
Fixed In Version: anaconda-20.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-30 17:11:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vojtěch Boček 2013-05-31 07:26:17 EDT
Description of problem:
Shared clipboard between host and guest in VM is not working in DVD.iso of Fedora 19 Beta RC4, spice-vdagent is however present and running. 

Version-Release number of selected component (if applicable):
Host: Fedora 19
spice-gtk3-0.19-1.fc19.x86_64
spice-server-0.12.3-1.fc19.x86_64

Guest: Fedora 19 Beta RC4 DVD.iso
anaconda 19.30-1
spice-vdagent-0.14.0-1.fc19.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Run DVD.iso in KVM
2. Copy something to cliboard in host OS
3. Try to paste it to anaconda in VM

Actual results:
It does not paste the text from clipboard.

Expected results:
It should paste the text from Host's clipboard.
Comment 1 Kamil Páral 2013-05-31 07:31:18 EDT
With Live images the clipboard sharing works without problems.
Comment 2 David Shea 2013-08-02 13:58:02 EDT
It looks like the installer environment is doing what it's supposed to as far as vdagent, reassigning to spice
Comment 3 Hans de Goede 2013-08-03 04:30:08 EDT
I've not investigated this, but this is likely caused by the spice-vdagent not being started as part of a proper login session registered with systemd-logind. spice-vdagentd uses systemd-logind to find out which spice-vdagent process belongs to the active session (there can be multiple spice-vdagent-s running when using fast user switching), so it knows where to send copy and paste data. There are probably messages related to this in /var/log/spice-vdagent.log, assuming rsyslog is running in the anaconda environment.

The easiest way to work around spice-vdagentd requiring a session which is properly registered with systemd-logind is to disable spice-vdagentd-s session tracking, note that if you do this there may only be one spice-vdagent process, as soon as there are 2 spice-vdagentd will refuse to serve either of them.

To disable the systemd-logind integration start spice-vdagentd with -X, note this option is new in spice-vdagent-0.14.0 and not available in older versions.
Comment 4 David Shea 2013-08-05 10:44:56 EDT
Thanks, Hans, that was it: there's no login session on the non-live media.

Note You need to log in before you can comment on or make changes to this bug.