Bug 969420 - Null safe dereferencing throws NPE
Null safe dereferencing throws NPE
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: BRE (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.0.0
Assigned To: Mario Fusco
Tomas Schlosser
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-31 07:45 EDT by Tomas Schlosser
Modified: 2014-08-06 16:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:16:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Schlosser 2013-05-31 07:45:16 EDT
Description of problem:
When null safe dereferencing is used in second (and later) condition it throws NPE.

Version-Release number of selected component (if applicable):
Drools 6.0.0.Beta2, Drools 6.0.0-SNAPSHOT (2013-05-31)

How reproducible:
run NullSafeDereferencingTest as submitted in pull request #203

Steps to Reproduce:
1. run the code

Actual results:
Null pointer exception caused by mvel optimizer

Expected results:
Everything runs fine

Additional info:
The test runs fine if (address != null, address.street == $street) is used. Also it works fine if null safe dereferencing is used in first condition.
Comment 1 Tomas Schlosser 2013-09-02 10:46:44 EDT
Verified in BRMS 6.0.0.ER2

Note You need to log in before you can comment on or make changes to this bug.