Bug 969484 - NPE when building thermostat-0.9.2-3
NPE when building thermostat-0.9.2-3
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xmvn (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-31 10:11 EDT by Severin Gehwolf
Modified: 2013-06-07 00:36 EDT (History)
4 users (show)

See Also:
Fixed In Version: xmvn-0.5.0-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 00:36:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Severin Gehwolf 2013-05-31 10:11:42 EDT
Description of problem:
Thermostat build fails for F19[1]. The same spec file succeeded in rawhide[2].

Version-Release number of selected component (if applicable):
Whatever is in the F19 build-repo.

How reproducible:
Build latest thermostat for F19 (0.9.2-3)

Actual results:
NPE on install part of %mvn_build

Expected results:
No NPE.

Additional info:
Feel free to add an -X switch to the %mvn_build call. It seems the failure is not always reproducible. I've managed to reproduce it twice (with debug not turned on).

[1] http://koji.fedoraproject.org/koji/taskinfo?taskID=5445050
[2] http://koji.fedoraproject.org/koji/buildinfo?buildID=423183
Comment 1 Stanislav Ochotnicky 2013-05-31 10:39:36 EDT
Sorry, this was actually fixed in -2 but when I built & submitted -3 for updates in F19, the buildroot override for -2 was removed for some reason. (-3 contained fix which didn't need override so I haven't set it). 

I am fixing this together with another bug affecting other packages so expect -4 shortly.
Comment 2 Fedora Update System 2013-05-31 11:26:05 EDT
xmvn-0.5.0-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xmvn-0.5.0-4.fc19
Comment 3 Stanislav Ochotnicky 2013-05-31 11:27:01 EDT
The build has been tagged into buildroot override so packages can be built as soon as repo is refreshed.
Comment 4 Fedora Update System 2013-05-31 14:12:29 EDT
Package xmvn-0.5.0-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xmvn-0.5.0-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9766/xmvn-0.5.0-4.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-06-07 00:36:02 EDT
xmvn-0.5.0-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.