Bug 969487 - the openstack cloud image should print boot messages also on ttyS0
Summary: the openstack cloud image should print boot messages also on ttyS0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: guest-images
Version: 6.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Joey Boggs
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1024389 (view as bug list)
Depends On:
Blocks: 1001730
TreeView+ depends on / blocked
 
Reported: 2013-05-31 14:15 UTC by Giulio Fidente
Modified: 2014-03-11 14:40 UTC (History)
9 users (show)

Fixed In Version: rhel-guest-image-6-6.5-20131101.2.el6
Doc Type: Bug Fix
Doc Text:
* The Red Hat Enterprise Linux guest image did not make use of the ttyS0 serial port by default, so tools that monitor the serial console log did not capture any information. This update adds a console log feature to the boot loader, and the Red Hat Enterprise Linux guest image will now print boot messages on the ttyS0 serial port and the standard console.
Clone Of:
Environment:
Last Closed: 2013-11-22 00:21:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1735 normal SHIPPED_LIVE rhel-guest-image bug fix and enhancement update 2013-11-20 22:04:16 UTC
Red Hat Bugzilla 1075125 None None None Never

Internal Links: 1075125

Description Giulio Fidente 2013-05-31 14:15:08 UTC
Description of problem:
openstack provides a "nova console-log" command which captures the messages sent to ttyS0; rhel images don't make use of ttyS0 by default so the console log seems to be empty


Version-Release number of selected component (if applicable):
rhel-server-x86_64-kvm-6.4_20130130.0-4.qcow2


Steps to Reproduce:
1. launch a rhel instance
2. check the console log

Comment 12 Joey Boggs 2013-10-30 01:42:54 UTC
*** Bug 1024389 has been marked as a duplicate of this bug. ***

Comment 14 Wei Shi 2013-11-02 05:35:02 UTC
Hi Joey,
  After you apply this patch, i can use virsh console to connect to our applance, but this is still something abnormal.

  The getty prompt appears earlier than the other bootup messages, if i type username at this time, i'll give me the bash session, but after all services is booted, there will have another getty prompt, which will interrupt with the earlier one, which make everything messed up.

  The way to workaround such problem is interact with getty prompt after all services launched.

Bringing up interface eth0:  
Determining IP information for eth0...
Red Hat Enterprise Linux Server release 6.4 (Santiago)
Kernel 2.6.32-428.el6.x86_64 on an x86_64

localhost.localdomain login:  done.
                                                           [  OK  ]
Starting system logger:                                    [  OK  ]
Starting rpcbind:                                          [  OK  ]


.....
.....
.....

Starting atd:                                              [  OK  ]
Starting rhsmcertd...                                      [  OK  ]


Red Hat Enterprise Linux Server release 6.4 (Santiago)
Kernel 2.6.32-428.el6.x86_64 on an x86_64

virtlab-66-84-199.englab.nay.redhat.com login: root

Comment 16 Wei Shi 2013-11-03 12:49:38 UTC
Verified:
  rhel-guest-image-6-6.5-20131101.2.el6

  We can watch the system booting messages through 'virsh console' and login to the appliance after getty apears and interact with the shell.

Starting crond:                                            [  OK  ]
Starting atd:                                              [  OK  ]
Starting rhsmcertd...                                      [  OK  ]

Red Hat Enterprise Linux Server release 6.4 (Santiago)
Kernel 2.6.32-428.el6.x86_64 on an x86_64

virtlab-66-84-199.englab.nay.redhat.com login: root
Last login: Sun Nov  3 20:38:04 on ttyS0

-bash-4.1# 
-bash-4.1# 
-bash-4.1# 
-bash-4.1# ls
anaconda-ks.cfg
-bash-4.1#

Comment 17 errata-xmlrpc 2013-11-22 00:21:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1735.html


Note You need to log in before you can comment on or make changes to this bug.