Bug 96950 - Not installing the gcc-java support makes all java awt based applications fail
Not installing the gcc-java support makes all java awt based applications fail
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc3 (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-06 17:56 EDT by Carsten Klein
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-17 13:49:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carsten Klein 2003-06-06 17:56:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529

Description of problem:
Note: This is not exactly a problem of gcc-java support, rather some
dependencies within the package and third vendor products, e.g. SUN j2re

I've just re-installed Red Hat 9 and left out gcc-java support.

This rendered all awt based applications unusable, due to a missing
libstdc++-libc-6.x.x.so.2 in /usr/lib.

Perhaps you could move this dependency / library out of the gcc-java support
package and move it to some other package, like, global-java-support or
something like that? This took me quite some time figuring out....

Thanks

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Actual Results:  AWT / Swing based applications would not work.

Additional info:
Comment 1 Jakub Jelinek 2003-06-17 13:49:25 EDT
libstdc++-3-libc6.2-2-2.10.0.so is provided by compat-libstdc++, not gcc-java.

Note You need to log in before you can comment on or make changes to this bug.