Bug 969519 - ipa-otpd.socket isn't enabled by default
ipa-otpd.socket isn't enabled by default
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: freeipa (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rob Crittenden
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-31 12:25 EDT by Nathaniel McCallum
Modified: 2013-06-14 00:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: freeipa-3.2.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-14 00:48:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathaniel McCallum 2013-05-31 12:25:02 EDT
This means that manual effort is required to achieve the zeroconf state.

Enabling this by default apparently requires FESCo approval: http://fedoraproject.org/wiki/Packaging:Systemd
Comment 1 Alexander Bokovoy 2013-05-31 14:04:11 EDT
I think ipa-server-install should enable it since ipa-otpd has no meaning without IPA itself being configured. There is no need to make ipa-otpd enabled by default at the system startup but rather managed via IPA.
Comment 2 Martin Kosek 2013-06-03 02:16:02 EDT
Right, this is how we enable other services. I will open an upstream ticket for that.
Comment 3 Martin Kosek 2013-06-03 02:16:29 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/3680
Comment 4 Rob Crittenden 2013-06-03 10:47:42 EDT
On dev call we decided that this should not be enabled by default, but managed by the IPA installer.

The existing systemd platform code can be used to enable/disable this service when IPA is installed/uninstalled.

On upgrade the service will need to be activated, see install/tools/ipa-upgradeconfig.

An LDAP service entry will need to be created for OTPD. There is a way to map the LDAP name to a systemd service name. The systemd start/stop functions will need to ignore services that end with .socket.
Comment 6 Fedora Update System 2013-06-07 10:36:26 EDT
freeipa-3.2.1-1.fc19, samba-4.0.6-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/freeipa-3.2.1-1.fc19,samba-4.0.6-3.fc19
Comment 7 Fedora Update System 2013-06-07 11:39:05 EDT
Package freeipa-3.2.1-1.fc19, samba-4.0.6-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing freeipa-3.2.1-1.fc19 samba-4.0.6-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10271/freeipa-3.2.1-1.fc19,samba-4.0.6-3.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-06-14 00:48:35 EDT
freeipa-3.2.1-1.fc19, samba-4.0.6-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.