Bug 969524 - qml-based systray plasma widgets unclickable on arm
qml-based systray plasma widgets unclickable on arm
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
20
arm Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 928049 (view as bug list)
Depends On:
Blocks: ARMTracker F20FinalBlocker
  Show dependency treegraph
 
Reported: 2013-05-31 13:06 EDT by Dennis Gilmore
Modified: 2014-07-10 15:12 EDT (History)
15 users (show)

See Also:
Fixed In Version: kdelibs-4.11.3-9.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-10 01:57:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 282975 None None None Never
KDE Software Compilation 312578 None None None Never

  None (edit)
Description Dennis Gilmore 2013-05-31 13:06:06 EDT
Description of problem:
running fedora 19 on arm i am unable to click on any plasma widgets, normal kde widgets are fine, most noticeable when getting notifications of package updates, you cant click on install, unable to remove notifications of people coming online in kopete

Version-Release number of selected component (if applicable):
i saw this with both qt-4.8.4-17.fc19 and qt-4.8.4-18.fc19

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Rex Dieter 2013-10-09 12:30:09 EDT
Is this still valid? Especially on f20?  If so, should probably consider it a blocker, and dedicate some more resources/manpower into it.
Comment 2 Rex Dieter 2013-11-21 12:56:24 EST
Confirmed on irc for f20. :(
Comment 3 Paul Whalen 2013-11-21 13:05:35 EST
Proposed Blocker for F20 - Default panel functionality

"All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use. "
Comment 4 Rex Dieter 2013-11-21 14:05:14 EST
Possible upstream match for this, https://bugs.kde.org/show_bug.cgi?id=312578
Comment 5 Rex Dieter 2013-11-21 14:10:16 EST
ah, and this older one, https://bugs.kde.org/show_bug.cgi?id=282975
Comment 6 Ngo Than 2013-11-25 07:56:19 EST
it seems a bug in plasma, but not in qt. reassign to correct component
Comment 7 Jan Grulich 2013-11-26 03:36:33 EST
It doesn't work probably only for applets in panel and written in QML (device notifier, NM applet etc.). I tried to put device notifier to desktop and here it works correctly. Tested on my Nexus 7 with Plasma active (KDE 4.10.x).
Comment 8 Adam Williamson 2013-11-27 12:19:18 EST
Discussed at 2013-11-27 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-27/f20-blocker-review-3.2013-11-27-17.01.log.txt . Accepted as a blocker per criterion cited in c#3 (or several others, really - makes KDE basically unusable on ARM).
Comment 9 Rex Dieter 2013-11-27 12:46:21 EST
updating summary, per irc debugging yesterday determined this only seems to affect qml-based plasma widgets embedded in the systray
Comment 10 Ngo Than 2013-11-29 11:24:30 EST
i have build qt/kdelibs/kde-workspace with -O0, jcapik tested qt build and still see the issue. He or pwhalen will test kdelibs/kde-workspace build today. I will post results here when the test is done.
Comment 11 Jaromír Cápík 2013-11-29 13:15:29 EST
kdelibs/kde-workspace tested -> didn't help
Comment 12 Jaroslav Reznik 2013-12-02 04:53:36 EST
As a workaround - could we put important Plasma widgets out of the panel to the desktop - for ARM images only? It's less than nice but could unblock us in case we would not be able to find the root for this issues as it seems upstream is fighting it too for some time.
Comment 13 Ngo Than 2013-12-02 06:26:02 EST
since we don't know the root for this issue and i don't think we have time to resolve this issue till 2013-12-10 for f20 release.

I full agree with jaroslav's suggestion that we should make such workaround.
Comment 14 Jaroslav Reznik 2013-12-02 07:25:45 EST
(In reply to Ngo Than from comment #13)
> since we don't know the root for this issue and i don't think we have time
> to resolve this issue till 2013-12-10 for f20 release.
> 
> I full agree with jaroslav's suggestion that we should make such workaround.

We discussed it with Kevin on #fedora-kde - he suggested possible solution, if you could try it, it would be great. On the other hand, I still believe we can find a proper solution for this one.
Comment 15 Rex Dieter 2013-12-02 07:50:16 EST
1.  Do we have confirmation that putting these applets outside of the systray works?  If so, what's an exhaustive list of applets that require moving?  So far, I think this includes:
* network management
* battery monitor

any others?


2.  Currently, kde-settings is a noarch package shared among all archs, we'd likely have to re-engineer the packaging to put in arch-specific changes (unless plasma scripting can somehow handle that part for us).   Any other implementation suggestions?
Comment 16 Rex Dieter 2013-12-02 08:01:51 EST
Per original submission, add to the existing list of affected applets:
* notifications
Comment 17 Jan Grulich 2013-12-02 08:04:12 EST
I can confirm that they work on desktop (at least on Nexus 7 with Plasma Active). The list of applets should include also device notifier applet.
Comment 18 Jaroslav Reznik 2013-12-02 08:13:15 EST
(In reply to Rex Dieter from comment #15)
For 1 - as far as I know, we have and see comment #17

For 2 - from Kevin from this morning: "Tweaking the Plasma configuration for ARM only isn't so straightforward, but I guess %ifarch in kde-settings, dropping a Plasma init script there, could work…"
Comment 19 Jan Grulich 2013-12-02 08:37:58 EST
I'm not sure whether it will work for networkmanagement applet and battery monitor, because when you put them on desktop, they are still collapsed to the icon (only device notifier is not and I was able to try only this one on my Nexus 7). So it's still basically popup applet.
Comment 20 Jan Grulich 2013-12-02 10:21:29 EST
Bad news!! I've just tried to put battery monitor to desktop (on ARM machine with F20) and there is the same regression so putting all widgets to desktop as a workaround won't help. It looks like there is a bug somewhere in Plasma popup applet.
Comment 21 Jan Grulich 2013-12-02 10:29:28 EST
It looks like upstream has a fix for that, see:
http://mail.kde.org/pipermail/active/2013-November/007228.html
Comment 22 Rex Dieter 2013-12-02 11:11:40 EST
trying out hackish workaround used on mer, http://goo.gl/ph8OqQ
Comment 23 Ngo Than 2013-12-02 11:38:21 EST
the kdelibs with the upstream workaround is in the build.

http://koji.fedoraproject.org/koji/taskinfo?taskID=6247897
Comment 24 Fedora Update System 2013-12-02 21:16:26 EST
kdelibs-4.11.3-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kdelibs-4.11.3-3.fc20
Comment 25 Jan Grulich 2013-12-03 08:23:39 EST
Confirming that the new build works, I've just tested it on jcapik's Pandora ARM machine.
Comment 26 Fedora Update System 2013-12-03 13:23:00 EST
Package kdelibs-4.11.3-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kdelibs-4.11.3-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22657/kdelibs-4.11.3-3.fc20
then log in and leave karma (feedback).
Comment 27 Paul Whalen 2013-12-03 13:46:09 EST
Confirmed working in F20-TC4 on the Trimslice.
Comment 28 Fedora Update System 2013-12-09 16:44:23 EST
kdelibs-4.11.3-9.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-23008/kdelibs-4.11.3-9.fc19
Comment 29 Fedora Update System 2013-12-10 01:57:49 EST
kdelibs-4.11.3-9.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 30 Fedora Update System 2013-12-11 21:52:41 EST
kdelibs-4.11.3-9.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 31 Jan Grulich 2013-12-13 09:44:10 EST
*** Bug 928049 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.