Bug 96953 - /dev/fd0 is always mounted read-only, cannot write to disk, even when logged in as 'root'
/dev/fd0 is always mounted read-only, cannot write to disk, even when logged ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mkbootdisk (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-06 18:10 EDT by Carsten Klein
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version: FC3T2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-05 07:22:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carsten Klein 2003-06-06 18:10:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529

Description of problem:
NOTE: This is not exactly a bug related to mkbootdisk, but since this was the
only component I've found that related to /dev/fd?, I took it... =)

I've noticed that, after upgrading from RH 8.0 to RH 9.0, access to /dev/fd0 is
always read-only.

I'm currently logged in as root, but I am not able to mount /dev/fd0 in
read-write mode, even when 

> mount -t auto -o rw /dev/fd0 /mnt/floppy

This will _always_ result in a read-only floppy drive.

RH 8.0 worked well with my current system configuration.

Thanks for looking after it...

PS: /dev/fd0 node is ok, root is the owner, group is floppy, access rights to
the device are rwxr-xr-x


My System Configuration incl. a VIA KT 400 chipset (Gigabyte GA-7VAX board) and
otherwise standard hardware incl. the floppy drive (Mitsumi).

I would have posted an excerpt of /etc/sysconfig/hwconf here, but due to
limitations of the get method of this form (all form fields are sent via
url-encoding-scheme to the server) I have not been able to fulfill the request.

Perhaps you have a look at bugzilla, too.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install RH 9 on my system
2. insert disk
3. try to mkfs.msdos /dev/fd0
4. fail due to read-only device
    

Actual Results:  floppy disk is read-only, even when logged in as root.

Expected Results:  guess what =)

Additional info:

Note You need to log in before you can comment on or make changes to this bug.