Bug 969544 - USB Redirection works in Full Screen but not in a window
USB Redirection works in Full Screen but not in a window
Status: CLOSED DUPLICATE of bug 842816
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.1.0
All Windows
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Uri Lublin
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-31 14:41 EDT by Allan Voss
Modified: 2015-09-22 09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-14 15:53:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allan Voss 2013-05-31 14:41:22 EDT
Description of problem:
When using Virt-viewer on Windows 7 (x86_64), USB Redirection works when in full screen mode. When in a window, however, users get "device not found error"

Version-Release number of selected component (if applicable):
3.1

How reproducible:
Very

Steps to Reproduce:
1. Create Windows 7 x86_64 guest
2. Enable USB redirection
3. Connect using Windows 7 x86_64 client and plug in USB

Actual results:
USB redirection works in full screen but fails in a window.

Expected results:
Consistent USB redirection

Additional info:
Comment 2 Uri Lublin 2013-06-02 05:31:45 EDT
I'll have to investigate the difference between full-screen mode and windowed-mode with regards to usbredir.

Since it's a Windows 7 client, this may be related to bug 842816.
Comment 5 Uri Lublin 2013-07-29 08:59:22 EDT
(In reply to Marc-Andre Lureau from comment #4)
> Uri, this bug is devel+, any news? thanks

Works for me with
    rhevm-spice-client-x64-cab-3.2-13 (which includes)
    mingw-virt-viewer-0.5.3-28 and
    usbclerk-win-0.1-11

Likely this bug is the same as bug 842816.
Comment 6 Marc-Andre Lureau 2013-08-14 09:11:48 EDT
Allan Voss, could you try with 3.2 version? as Uri said, this is probably a dup of bug 842816.

Note You need to log in before you can comment on or make changes to this bug.