Bug 96956 - MultiLingual P2FS broken
MultiLingual P2FS broken
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Archit Shah
Jon Orris
:
Depends On:
Blocks: 88926
  Show dependency treegraph
 
Reported: 2003-06-06 18:57 EDT by Jon Orris
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-13 13:59:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Orris 2003-06-06 18:57:39 EDT
Description of problem:
@32133

Create an article & publish it.
Create a german copy & publish.
P2FS publishes the english version fine, but croaks on the german one.


2003-06-06 18:33:35,743 [xport] ERROR publishToFile.QueueManager -
PublishToFileException.  itemId=24005 task=republish on item 24005(parent 20013)
destination=null failCount=10 error=IO Error when reading html:
http://localhost:8080/ccm/articles/grick.de.jsp?templateContext=public
com.arsdigita.cms.publishToFile.PublishToFileException: IO Error when reading
html: http://localhost:8080/ccm/articles/grick.de.jsp?templateContext=public
	at
com.arsdigita.cms.publishToFile.HttpHTMLProvider.fetchHTML(HttpHTMLProvider.java:85)
	at com.arsdigita.cms.publishToFile.PublishToFile.readHTML(PublishToFile.java:361)
	at
com.arsdigita.cms.publishToFile.PublishToFile.publishPage(PublishToFile.java:316)
	at com.arsdigita.cms.publishToFile.PublishToFile.publish(PublishToFile.java:240)
	at com.arsdigita.cms.publishToFile.PublishToFile.republish(PublishToFile.java:251)
	at com.arsdigita.cms.publishToFile.PublishToFile.doTask(PublishToFile.java:154)
	at
com.arsdigita.cms.publishToFile.QueueManager.processQueueBlock(QueueManager.java:429)
	at
com.arsdigita.cms.publishToFile.QueueManager.processQueueItems(QueueManager.java:358)
	at com.arsdigita.cms.publishToFile.QueueManager.run(QueueManager.java:315)
	at java.lang.Thread.run(Thread.java:512)
Comment 1 Justin Ross 2003-06-10 20:26:32 EDT
Fixed in perforce change 32241.  BTW, Jon, also fixed the permission context
propagation stuff, so you should get the edit links back.
Comment 2 Jon Orris 2003-06-11 09:29:48 EDT
I now get the following error in the log. This change also appears to cause bz 97193

2003-06-11 09:30:58,370 [xport] ERROR publishToFile.QueueManager - Task
republish on item 10004(parent 14033) failed:  itemId=10004 task=republish on
item 10004(parent 14033) destination=null failCount=0 
error= (root cause: null (root cause: ERROR:  Cannot insert a duplicate key into
unique index publish_to_fs_files_un
))
com.arsdigita.persistence.PersistenceException:  (root cause:
com.arsdigita.persistence.proto.engine.rdbms.RDBMSEngine$1: null (root cause:
ERROR:  Cannot insert a duplicate key into unique index publish_
to_fs_files_un
))
        at com.arsdigita.persistence.DataObjectImpl.save(DataObjectImpl.java:365)
        at com.arsdigita.domain.DomainObject.save(DomainObject.java:315)
        at
com.arsdigita.cms.publishToFile.PublishToFile.publishPageAtDocRoot(PublishToFile.java:462)
        at
com.arsdigita.cms.publishToFile.PublishToFile.publishPage(PublishToFile.java:316)
        at
com.arsdigita.cms.publishToFile.PublishToFile.publish(PublishToFile.java:240)
        at
com.arsdigita.cms.publishToFile.PublishToFile.republish(PublishToFile.java:251)
        at
com.arsdigita.cms.publishToFile.PublishToFile.doTask(PublishToFile.java:154)
        at
com.arsdigita.cms.publishToFile.QueueManager.processQueueBlock(QueueManager.java:429)
        at
com.arsdigita.cms.publishToFile.QueueManager.processQueueItems(QueueManager.java:358)
        at com.arsdigita.cms.publishToFile.QueueManager.run(QueueManager.java:315)
        at java.lang.Thread.run(Thread.java:512)
Root cause: 
com.arsdigita.persistence.proto.engine.rdbms.RDBMSEngine$1: null (root cause:
ERROR:  Cannot insert a duplicate key into unique index publish_to_fs_files_un
)
        at
com.arsdigita.persistence.proto.engine.rdbms.RDBMSEngine.execute(RDBMSEngine.java(Compiled
Code))
        at
com.arsdigita.persistence.proto.engine.rdbms.RDBMSEngine.flush(RDBMSEngine.java(Compiled
Code))
        at
com.arsdigita.persistence.proto.engine.rdbms.RDBMSEngine.flush(RDBMSEngine.java(Compiled
Code))
        at
com.arsdigita.persistence.proto.Session.flushInternal(Session.java(Compiled Code))
        at com.arsdigita.persistence.proto.Session.flush(Session.java(Compiled
Code))
        at com.arsdigita.persistence.DataObjectImpl.save(DataObjectImpl.java:358)
        at com.arsdigita.domain.DomainObject.save(DomainObject.java:315)
        at
com.arsdigita.cms.publishToFile.PublishToFile.publishPageAtDocRoot(PublishToFile.java:462)
        at
com.arsdigita.cms.publishToFile.PublishToFile.publishPage(PublishToFile.java:316)
        at
com.arsdigita.cms.publishToFile.PublishToFile.publish(PublishToFile.java:240)
        at
com.arsdigita.cms.publishToFile.PublishToFile.republish(PublishToFile.java:251)
        at
com.arsdigita.cms.publishToFile.PublishToFile.doTask(PublishToFile.java:154)
        at
com.arsdigita.cms.publishToFile.QueueManager.processQueueBlock(QueueManager.java:429)
        at
com.arsdigita.cms.publishToFile.QueueManager.processQueueItems(QueueManager.java:358)
        at com.arsdigita.cms.publishToFile.QueueManager.run(QueueManager.java:315)
        at java.lang.Thread.run(Thread.java:512)

Comment 3 Justin Ross 2003-06-11 11:11:26 EDT
Jon, at perforce 32258 I am able to publish non-primary languages.
Comment 4 Jon Orris 2003-06-11 15:47:24 EDT
I think this is due to a collision in the image asset name.
create table publish_to_fs_files (
...
    file_name   varchar(1000)
                constraint publish_to_fs_files_un unique
 select * from publish_to_fs_files;


 id | draft_id | item_id |                 file_name
----+----------+---------+--------------------------------------------
  5 |     9028 |    9113 | /articles/bar/baz.en.html
  6 |     9102 |    9113 | /articles/bar9198_public_folder.png.png
  7 |     9028 |    9113 | /articles/bar/baz$alternate.en.html
  8 |     9102 |    9113 | /articles/bar9198_alternate_folder.png.png
  9 |     9028 |    9113 | /articles/bar/baz$summary.en.html
 10 |     9102 |    9113 | /articles/bar9198_summary_folder.png.png
(6 rows)

Note You need to log in before you can comment on or make changes to this bug.