Bug 969593 - drupal7: More RPM build updates
drupal7: More RPM build updates
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: drupal7 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-31 16:56 EDT by Shawn Iwinski
Modified: 2013-06-18 16:47 EDT (History)
4 users (show)

See Also:
Fixed In Version: drupal7-7.22-5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 02:47:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
drupal7-rpmbuild-updates.patch (11.77 KB, patch)
2013-05-31 16:56 EDT, Shawn Iwinski
no flags Details | Diff
drupal7-rpmbuild-updates.patch (11.76 KB, patch)
2013-05-31 17:01 EDT, Shawn Iwinski
no flags Details | Diff

  None (edit)
Description Shawn Iwinski 2013-05-31 16:56:31 EDT
Created attachment 755373 [details]
drupal7-rpmbuild-updates.patch

Attached patch implements the following:
- Adds version to virtual-provides
- Removes hidden (Drupal *.info "hidden = TRUE") virtual-provides
- Adds core pkg virtual-provides
- Adds virtual-requires (only "drupal7(core)")
- Fixes rpmlint "macro-in-%changelog"


Version-Release number of selected component (if applicable):
drupal7-7.22-4


Additional info:
https://github.com/siwinski/fedora-drupal7/commit/b2ef658f477ca276319b31cb81161b62e612bdc7
Comment 1 Shawn Iwinski 2013-05-31 17:01:44 EDT
Created attachment 755375 [details]
drupal7-rpmbuild-updates.patch

Minor typo in original patch
Comment 2 Gwyn Ciesla 2013-06-03 11:11:26 EDT
So this is essentially the auto-requires side of the coin?
Comment 3 Shawn Iwinski 2013-06-03 11:15:06 EDT
(In reply to Jon Ciesla from comment #2)
> So this is essentially the auto-requires side of the coin?

That's part of it.  Although only "drupal(core)" is auto-required because there are some sub-modules that would pull in optional (and sometimes quite large and/or non-packaged) dependencies.

Other additions include:
- Adds version to virtual-provides
- Removes hidden (Drupal *.info "hidden = TRUE") virtual-provides
- Adds core pkg virtual-provides
- Fixes rpmlint "macro-in-%changelog"
Comment 4 Gwyn Ciesla 2013-06-03 11:33:02 EDT
Reasonable.  Thanks!
Comment 5 Fedora Update System 2013-06-03 11:46:44 EDT
drupal7-7.22-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/drupal7-7.22-5.fc19
Comment 6 Fedora Update System 2013-06-03 11:47:09 EDT
drupal7-7.22-5.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/drupal7-7.22-5.el6
Comment 7 Fedora Update System 2013-06-03 11:47:36 EDT
drupal7-7.22-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/drupal7-7.22-5.fc17
Comment 8 Fedora Update System 2013-06-03 11:48:03 EDT
drupal7-7.22-5.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/drupal7-7.22-5.el5
Comment 9 Fedora Update System 2013-06-03 11:48:26 EDT
drupal7-7.22-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/drupal7-7.22-5.fc18
Comment 10 Fedora Update System 2013-06-03 15:29:47 EDT
Package drupal7-7.22-5.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing drupal7-7.22-5.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-6067/drupal7-7.22-5.el5
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-06-03 15:30:53 EDT
Package drupal7-7.22-5.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing drupal7-7.22-5.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-6070/drupal7-7.22-5.el6
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2013-06-13 02:47:23 EDT
drupal7-7.22-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2013-06-13 22:29:04 EDT
drupal7-7.22-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2013-06-13 22:29:58 EDT
drupal7-7.22-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2013-06-18 16:46:31 EDT
drupal7-7.22-5.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2013-06-18 16:47:37 EDT
drupal7-7.22-5.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.