Bug 969648 - fedup to F19 fails due to read-only root if "data=writeback" in mount opts
fedup to F19 fails due to read-only root if "data=writeback" in mount opts
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: fedup-dracut (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-01 08:41 EDT by David Keegan
Modified: 2015-02-17 10:24 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 10:24:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Keegan 2013-06-01 08:41:33 EDT
Description of problem:

Using fedup-0.7.3 to upgrade from f18 to f19 beta fails.

Version-Release number of selected component (if applicable):

fedup-dracut-0.7.2

How reproducible:

Very.

Steps to Reproduce:
1. Run fedup on F18 to successful completion on UEFI system.
2. Reboot selecting new "System Upgrade" grub entry.

Actual results:

There is grubby failure due to read-only filesystem. Then it seems to be preparing an rpm transaction, at the end of which there is an error acquiring an rpm lock due to read-only filesystem. The system then reboots. The process
repeats of "System Upgrade" is selected again.

Expected results:

System Upgrade boot should install f19. That didn't happen.

Additional info:

The hardware has UEFI boot. It was upgraded from F17 to F18 beta several months ago using fedup without any problems.

Following the same procedure I was able to upgrade a BIOS system from F18 to F19 beta without any problems.
Comment 1 Jakob Hirsch 2013-07-04 05:28:07 EDT
Same problem here. I solved this by replacing this entry in my /etc/fstab:

UUID=6b694b71-bc0d-4290-a3cf-2c561a281ab1      /       ext4    relatime,journal_async_commit,delalloc,auto_da_alloc,discard,data=writeback 1 1

with this simple one:

/dev/sda1  /    ext4    defaults        1 1

I don't know if it was because of the UUID instead of the device or the excessive options, though.

If this doesn't help, you could try to hack your /usr/lib/systemd/upgrade-prep.sh by insert a "mount -o remount,rw /" before the  line running new-kernel-pkg, this is really ugly though.
Comment 2 mlg9000@yahoo.com 2013-07-04 15:22:59 EDT
I can confirm the same issue, although I have UEFI disabled.

Fedup from 17 to 18 = worked fine

To update to 19 I had to change my /etc/fstab from:

/dev/mapper/vg_bullet-lv_root /                       ext4    defaults,discard,noatime,nodiratime,barrier=0,data=writeback        1 1

to:

/dev/mapper/vg_bullet-lv_root /                       ext4    defaults 1 1
Comment 3 John McInnes 2013-07-05 19:57:28 EDT
x86_64 Same here. I had:

UUID=.....      /        ext4    noatime,data=writeback,acl,user_xattr  1 1

..and changing to.. 

/dev/sda3   /   ext4     defaults     1 1

..fixed it.
Comment 4 mlg9000@yahoo.com 2013-07-05 20:07:49 EDT
The issue is data=writeback, the rest of the options work fine.
Comment 5 Will Woods 2013-08-14 15:37:32 EDT
It's also the only option you all have in common.

What happens if you add "data=writeback" back to your fstab after the upgrade? Does your root device end up being read-only again?
Comment 6 Urban Widmark 2013-09-07 14:30:41 EDT
data=writeback in the fstab causes problems in F19, with root being left mounted read only.

The error is because ext4 refuses to remount with different 'data' mount option. So something is mounting it without the data option in F19. This can be verified by looking at the /proc/mounts listing.


This is as I understand it not a new thing with ext4 (google finds errors going back several years). No idea why it worked in F18, maybe the fstab entry is used somewhere else (initramfs?) or maybe F18 had some kernel patch to allow it. I did not have any mount options listed in my grub.cfg kernel command line.
Comment 7 Fedora End Of Life 2015-01-09 13:17:15 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 8 Fedora End Of Life 2015-02-17 10:24:55 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.