Bug 969663 - mate-session causes constant 25% CPU usage by trying to keep two caja processes running at once
mate-session causes constant 25% CPU usage by trying to keep two caja process...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mate-session-manager (Show other bugs)
19
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-01 11:43 EDT by Dominik 'Rathann' Mierzejewski
Modified: 2013-07-09 21:22 EDT (History)
7 users (show)

See Also:
Fixed In Version: mate-file-manager-1.6.1-9.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-09 21:22:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Hopefully relevant log messages from /var/log/messages during session startup. (11.33 KB, text/plain)
2013-06-01 15:41 EDT, Dominik 'Rathann' Mierzejewski
no flags Details

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2013-06-01 11:43:24 EDT
Description of problem:
After graphical log in, the following three processes begin taking 10% of CPU each:
mate-session
dbus-daemon
X

Version-Release number of selected component (if applicable):
mate-session-manager-1.6.0-3.fc19.x86_64
dbus-1.6.8-5.fc19.x86_64
xorg-x11-server-Xorg-1.14.1-2.fc19.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Log in to MATE from lightdm

Actual results:
CPU usage is constantly at 30%.

Expected results:
CPU usage should be much lower, around 1%.

Additional info:
This doesn't happen with a newly-created user nor after a text-console login.
Setting SELinux to permissive has no effect, no AVCs found in /var/log/audit./audit.log
Comment 1 Dominik 'Rathann' Mierzejewski 2013-06-01 11:56:01 EDT
There's a marked delay before X session manager screen shows up after systemctl isolate graphical.target as well as after clicking System->Log out. The delay is around 20 seconds.

Additionally, these errors can be found in /var/log/messages when I log out of the graphical session:

Jun  1 17:49:15 amaterasu NetworkManager[354]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.open: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.122': no such name
Jun  1 17:49:15 amaterasu NetworkManager[354]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.protected: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.122': no such name
Jun  1 17:49:15 amaterasu NetworkManager[354]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.open: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.122': no such name
Jun  1 17:49:15 amaterasu NetworkManager[354]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-network: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.122': no such name
Jun  1 17:49:15 amaterasu NetworkManager[354]: <warn> error requesting auth for org.freedesktop.NetworkManager.sleep-wake: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.122': no such name
Jun  1 17:49:15 amaterasu NetworkManager[354]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-wifi: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.122': no such name
Jun  1 17:49:15 amaterasu NetworkManager[354]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-wwan: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.122': no such name
Jun  1 17:49:15 amaterasu NetworkManager[354]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-wimax: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.122': no such name
Jun  1 17:49:15 amaterasu NetworkManager[354]: <warn> error requesting auth for org.freedesktop.NetworkManager.network-control: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.122': no such name
Jun  1 17:49:15 amaterasu NetworkManager[354]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.protected: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.122': no such name
Jun  1 17:49:15 amaterasu NetworkManager[354]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.open: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.122': no such name
Jun  1 17:49:15 amaterasu NetworkManager[354]: <warn> error requesting auth for org.freedesktop.NetworkManager.settings.modify.system: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.122': no such name
Jun  1 17:49:15 amaterasu NetworkManager[354]: <warn> error requesting auth for org.freedesktop.NetworkManager.settings.modify.own: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.122': no such name
Jun  1 17:49:15 amaterasu NetworkManager[354]: <warn> error requesting auth for org.freedesktop.NetworkManager.settings.modify.hostname: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.122': no such name
Comment 2 Dominik 'Rathann' Mierzejewski 2013-06-01 15:41:03 EDT
Created attachment 755632 [details]
Hopefully relevant log messages from /var/log/messages during session startup.
Comment 3 Dan Mashal 2013-06-04 10:40:30 EDT
I've seen this happen with other DE's installed. Do you have only MATE installed? How did you install it? netinstall? live cd? DVD? yum?
Comment 4 Dan Mashal 2013-06-05 05:01:22 EDT
PulseAudio/Gnome-Keyring/NetworkManager bug.
Comment 5 Dominik 'Rathann' Mierzejewski 2013-06-05 18:13:43 EDT
I have only MATE installed, yes. This Fedora installation is a fresh F18 installation (with /home filesystem dating back to 2000), which was upgraded to F19 using yum dist-sync.

I'll try to install another DE and check.
Comment 6 Dominik 'Rathann' Mierzejewski 2013-06-06 17:43:37 EDT
This doesn't happen in LXDE or Openbox session.
Comment 7 Dominik 'Rathann' Mierzejewski 2013-06-08 16:03:00 EDT
Looks like it's gone after tonight's batch of updates. Not sure which package fixed it, but here's the list:
Jun 08 21:55:32 Updated: libgcc-4.8.1-1.fc19.x86_64
Jun 08 21:55:32 Updated: libstdc++-4.8.1-1.fc19.x86_64
Jun 08 21:55:32 Updated: gdk-pixbuf2-2.28.2-1.fc19.x86_64
Jun 08 21:55:33 Updated: systemd-libs-204-6.fc19.x86_64
Jun 08 21:55:34 Updated: systemd-204-6.fc19.x86_64
Jun 08 21:55:34 Updated: libgudev1-204-6.fc19.x86_64
Jun 08 21:55:34 Updated: 1:NetworkManager-glib-0.9.8.2-1.fc19.x86_64
Jun 08 21:55:38 Updated: 1:java-1.7.0-openjdk-1.7.0.19-2.3.9.12.fc19.x86_64
Jun 08 21:55:38 Updated: 1:libreoffice-ure-4.1.0.0-7.beta2.fc19.x86_64
Jun 08 21:55:39 Updated: harfbuzz-0.9.18-2.fc19.x86_64
Jun 08 21:55:39 Installed: harfbuzz-icu-0.9.18-2.fc19.x86_64
Jun 08 21:55:39 Updated: libnm-gtk-0.9.8.2-1.fc19.x86_64
Jun 08 21:55:39 Updated: systemd-sysv-204-6.fc19.x86_64
Jun 08 21:55:39 Updated: system-config-printer-libs-1.4.1-6.fc19.noarch
Jun 08 21:55:40 Updated: 1:autocorr-en-4.1.0.0-7.beta2.fc19.noarch
Jun 08 21:55:40 Updated: 1:NetworkManager-0.9.8.2-1.fc19.x86_64
Jun 08 21:55:40 Updated: firewalld-0.3.3-2.fc19.noarch
Jun 08 21:55:41 Updated: nm-connection-editor-0.9.8.2-1.fc19.x86_64
Jun 08 21:55:41 Updated: mate-desktop-libs-1.6.1-6.fc19.x86_64
Jun 08 21:55:42 Installed: mate-desktop-1.6.1-6.fc19.x86_64
Jun 08 21:55:42 Updated: mate-file-manager-extensions-1.6.1-5.fc19.x86_64
Jun 08 21:55:43 Updated: mate-file-manager-1.6.1-5.fc19.x86_64
Jun 08 21:55:43 Updated: mate-menus-libs-1.6.0-3.fc19.x86_64
Jun 08 21:55:43 Updated: mate-menus-1.6.0-3.fc19.x86_64
Jun 08 21:55:43 Updated: 1:autocorr-ja-4.1.0.0-7.beta2.fc19.noarch
Jun 08 21:55:43 Updated: system-config-keyboard-base-1.3.1-14.fc19.x86_64
Jun 08 21:55:44 Updated: libquadmath-4.8.1-1.fc19.x86_64
Jun 08 21:55:44 Updated: 1:autocorr-pl-4.1.0.0-7.beta2.fc19.noarch
Jun 08 21:55:44 Updated: selinux-policy-3.12.1-48.fc19.noarch
Jun 08 21:55:44 Updated: xorg-x11-server-common-1.14.1-4.fc19.x86_64
Jun 08 21:55:44 Updated: 1:autocorr-de-4.1.0.0-7.beta2.fc19.noarch
Jun 08 21:55:44 Updated: 1:libreoffice-opensymbol-fonts-4.1.0.0-7.beta2.fc19.noarch
Jun 08 21:55:45 Updated: 1:libreoffice-writer-4.1.0.0-7.beta2.fc19.x86_64
Jun 08 21:55:55 Updated: 1:libreoffice-core-4.1.0.0-7.beta2.fc19.x86_64
Jun 08 21:55:55 Updated: 1:libreoffice-graphicfilter-4.1.0.0-7.beta2.fc19.x86_64
Jun 08 21:55:55 Updated: 1:libreoffice-draw-4.1.0.0-7.beta2.fc19.x86_64
Jun 08 21:55:55 Updated: 1:libreoffice-pdfimport-4.1.0.0-7.beta2.fc19.x86_64
Jun 08 21:55:55 Updated: 1:autocorr-fr-4.1.0.0-7.beta2.fc19.noarch
Jun 08 21:55:56 Updated: 1:libreoffice-langpack-fr-4.1.0.0-7.beta2.fc19.x86_64
Jun 08 21:55:58 Updated: 1:libreoffice-langpack-pl-4.1.0.0-7.beta2.fc19.x86_64
Jun 08 21:55:58 Updated: 1:libreoffice-impress-4.1.0.0-7.beta2.fc19.x86_64
Jun 08 21:55:58 Updated: 1:libreoffice-langpack-en-4.1.0.0-7.beta2.fc19.x86_64
Jun 08 21:55:58 Updated: 1:libreoffice-math-4.1.0.0-7.beta2.fc19.x86_64
Jun 08 21:56:00 Updated: 1:libreoffice-langpack-ja-4.1.0.0-7.beta2.fc19.x86_64
Jun 08 21:56:01 Updated: 1:libreoffice-langpack-de-4.1.0.0-7.beta2.fc19.x86_64
Jun 08 21:56:02 Updated: 1:libreoffice-calc-4.1.0.0-7.beta2.fc19.x86_64
Jun 08 21:56:02 Updated: 1:libreoffice-xsltfilter-4.1.0.0-7.beta2.fc19.x86_64
Jun 08 21:56:02 Updated: xorg-x11-server-Xorg-1.14.1-4.fc19.x86_64
Jun 08 21:56:05 Updated: selinux-policy-targeted-3.12.1-48.fc19.noarch
Jun 08 21:56:05 Updated: libgfortran-4.8.1-1.fc19.x86_64
Jun 08 21:56:06 Updated: system-config-keyboard-1.3.1-14.fc19.x86_64
Jun 08 21:56:06 Updated: network-manager-applet-0.9.8.2-1.fc19.x86_64
Jun 08 21:56:06 Updated: firewall-config-0.3.3-2.fc19.noarch
Jun 08 21:56:06 Updated: system-config-printer-udev-1.4.1-6.fc19.x86_64
Jun 08 21:56:07 Updated: system-config-printer-1.4.1-6.fc19.x86_64
Jun 08 21:56:08 Updated: webkitgtk-2.0.2-2.fc19.x86_64
Jun 08 21:56:08 Updated: icedtea-web-1.4-1.fc19.x86_64
Jun 08 21:56:09 Updated: mate-window-manager-1.6.1-1.fc19.x86_64
Jun 08 21:56:10 Updated: llvm-libs-3.3-0.5.rc2.fc19.x86_64
Jun 08 21:56:10 Updated: libibverbs-1.1.6-7.fc19.x86_64
Jun 08 21:56:10 Updated: setup-2.8.71-1.fc19.noarch
Jun 08 21:56:11 Updated: libgomp-4.8.1-1.fc19.x86_64
Jun 08 21:56:11 Updated: dtc-1.3.0-8.fc19.x86_64
Jun 08 21:56:11 Updated: libbsd-0.5.1-2.fc19.x86_64
Jun 08 21:56:11 Updated: shim-unsigned-0.3-2.fc19.x86_64
Jun 08 21:56:11 Updated: libtool-ltdl-2.4.2-16.fc19.x86_64
Jun 08 21:56:12 Updated: strace-4.8-1.fc19.x86_64
Jun 08 21:56:13 Updated: mate-themes-1.6.1-1.fc19.noarch
Jun 08 21:56:14 Updated: grubby-8.26-2.fc19.x86_64
Jun 08 21:56:14 Updated: libldb-1.1.15-3.fc19.x86_64
Jun 08 21:56:14 Updated: libgcc-4.8.1-1.fc19.i686
Jun 08 21:56:14 Updated: systemd-libs-204-6.fc19.i686
Jun 08 21:56:14 Updated: libstdc++-4.8.1-1.fc19.i686
Jun 08 21:56:15 Updated: harfbuzz-0.9.18-2.fc19.i686
Jun 08 21:56:15 Updated: gdk-pixbuf2-2.28.2-1.fc19.i686
Jun 08 21:56:16 Updated: libgomp-4.8.1-1.fc19.i686
Comment 8 Dominik 'Rathann' Mierzejewski 2013-06-09 20:20:03 EDT
Looks like it's back after a reboot (I usually just suspend and resume so I haven't noticed it until the reboot). Reopening.
Comment 9 Dominik 'Rathann' Mierzejewski 2013-06-28 16:37:42 EDT
With the help of powertop I was able to identify the culprit: caja. Killing it and restarting manually with the same command that is used in session startup (caja -n) seems to resolve the excessive cpu usage issue until logout.
Comment 10 Dominik 'Rathann' Mierzejewski 2013-06-28 16:43:48 EDT
I can see two caja processes: one with constant PID and one whose PID is changing every two or so seconds, which means it's dying and the parent is forking new child each time.
Comment 11 Dan Mashal 2013-06-28 16:51:09 EDT
You should never have 2 caja's running, caja should start up and run as a daemon in the backtground. 

There were some selinux policy issues and some gvfs, dbus and gtk issues as well. 

Did you get the latest updates from updates-testing?
Comment 12 Wolfgang Ulbrich 2013-06-28 17:13:03 EDT
(In reply to Dominik 'Rathann' Mierzejewski from comment #10)
> I can see two caja processes: one with constant PID and one whose PID is
> changing every two or so seconds, which means it's dying and the parent is
> forking new child each time.

Which caja and mate-desktop version are running?
What is the output of
gsettings get org.mate.session.required-components filemanager   ?
This key is hopefully empty. If not delete the key value.

With latest mate-file-manager-1.6.1-6.fc19 and mate-desktop-1.6.1-8.fc19
caja starts with /etc/xdg/autostart/caja-autostart.desktop.
Comment 13 Dominik 'Rathann' Mierzejewski 2013-06-28 17:28:23 EDT
$ rpm -q mate-file-manager mate-desktop
mate-file-manager-1.6.1-6.fc19.x86_64
mate-desktop-1.6.1-8.fc19.x86_64
$ gsettings get org.mate.session.required-components filemanager
''

/etc/xdg/autostart/caja-autostart.desktop is present and I see it in System->Preferences->Startup Applications.
Comment 14 Dan Mashal 2013-06-28 18:09:50 EDT
disabling "session saving" cleared out some old gsettings issues and resolved this, but turning it back on cause the issue to reappear. will work with upstream on this.
Comment 15 Dominik 'Rathann' Mierzejewski 2013-06-28 18:14:53 EDT
For the record, the issue seems to be mate-session starting caja both from saved session and from /etc/xdg/autostart, which explains why disabling session saving solves it. Disabling the autostart of caja desktop in System->Preferences->Startup Applications seems like a good workaround for now.
Comment 16 Wolfgang Ulbrich 2013-06-29 03:59:39 EDT
The session state is stored here. ~.config/mate-session/saved-session/
To clear this folder should solve your issue.
Comment 17 Wolfgang Ulbrich 2013-06-29 18:42:44 EDT
*** Bug 978598 has been marked as a duplicate of this bug. ***
Comment 18 Fedora Update System 2013-06-30 20:47:10 EDT
mate-file-manager-1.6.1-9.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-file-manager-1.6.1-9.fc19
Comment 19 Fedora Update System 2013-07-01 20:27:16 EDT
Package mate-file-manager-1.6.1-9.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-file-manager-1.6.1-9.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12106/mate-file-manager-1.6.1-9.fc19
then log in and leave karma (feedback).
Comment 20 Fedora Update System 2013-07-09 21:22:57 EDT
mate-file-manager-1.6.1-9.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.