Bug 969715 - SELinux is preventing /usr/bin/rm from 'write' accesses on the directory xinitrc.d.
SELinux is preventing /usr/bin/rm from 'write' accesses on the directory xini...
Status: CLOSED DUPLICATE of bug 969711
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:95dfdd9135b4e5a999a9326d864...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-01 21:33 EDT by Moez Roy
Modified: 2013-06-03 01:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 01:58:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-06-01 21:33:04 EDT
Description of problem:
SELinux is preventing /usr/bin/rm from 'write' accesses on the directory xinitrc.d.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that rm should be allowed write access on the xinitrc.d directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep rm /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:system_r:initrc_t:s0
Target Context                system_u:object_r:bin_t:s0
Target Objects                xinitrc.d [ dir ]
Source                        rm
Source Path                   /usr/bin/rm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           coreutils-8.21-11.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-47.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-300.fc19.x86_64 #1 SMP Fri
                              May 24 22:17:06 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-06-01 21:21:49 EDT
Last Seen                     2013-06-01 21:21:51 EDT
Local ID                      daf01b40-838d-4a94-b5c6-088b33c2fb06

Raw Audit Messages
type=AVC msg=audit(1370136111.496:525): avc:  denied  { write } for  pid=4018 comm="rm" name="xinitrc.d" dev="sda2" ino=2359463 scontext=unconfined_u:system_r:initrc_t:s0 tcontext=system_u:object_r:bin_t:s0 tclass=dir


type=SYSCALL msg=audit(1370136111.496:525): arch=x86_64 syscall=unlinkat success=no exit=EACCES a0=ffffffffffffff9c a1=1e6b0c0 a2=0 a3=7fff4b1f30a0 items=0 ppid=3989 pid=4018 auid=1000 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=1 tty=pts0 comm=rm exe=/usr/bin/rm subj=unconfined_u:system_r:initrc_t:s0 key=(null)

Hash: rm,initrc_t,bin_t,dir,write

Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-300.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-06-03 01:58:00 EDT

*** This bug has been marked as a duplicate of bug 969711 ***

Note You need to log in before you can comment on or make changes to this bug.