Bug 96972 - (1394 SBP2)Rescanning SCSI bus with attached IEEE-1394 devices yields oops in kernel 2.4.20-18.9
(1394 SBP2)Rescanning SCSI bus with attached IEEE-1394 devices yields oops in...
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-07 08:59 EDT by Didier
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-29 08:03:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Script to scan IEEE1394 port and map devices to SCSI (2.61 KB, text/plain)
2003-06-07 09:00 EDT, Didier
no flags Details
lspci (5.79 KB, text/plain)
2003-06-07 09:06 EDT, Didier
no flags Details
lsmod (1.85 KB, text/plain)
2003-06-07 09:07 EDT, Didier
no flags Details
OOPS from /var/log/messages (8.08 KB, text/plain)
2003-06-07 09:09 EDT, Didier
no flags Details

  None (edit)
Description Didier 2003-06-07 08:59:38 EDT
Description of problem:

When running the "firewire_rescan-scsi-bus.sh"-script with attached IEEE-1394
devices, the kernel oopses.


Version-Release number of selected component (if applicable):

kernel 2.4.20-18.9

How reproducible:
Always

Steps to Reproduce:
1. attach IEEE-1394 device(s) (external harddisk & Sony DRU-500A DVD+-RW)
2. ./firewire_rescan-scsi-bus.sh , to map IEEE1394 to virtual SCSI devices
3.
    
Actual results:

oops


Expected results:

IEEE1394 devices should be mapped to /dev/sda, /dev/sdb, ...


Additional info:

This worked well with kernel 2.4.20-13.9, and hence is a regression.

Could this bug be a related to bug #92193 (which does not mention an oops) ?

Concerning the attached lsmod : kernel is tainted due to VMware modules.
Comment 1 Didier 2003-06-07 09:00:56 EDT
Created attachment 92229 [details]
Script to scan IEEE1394 port and map devices to SCSI
Comment 2 Didier 2003-06-07 09:06:55 EDT
Created attachment 92230 [details]
lspci

lspci -vt
lspci -vv
Comment 3 Didier 2003-06-07 09:07:15 EDT
Created attachment 92231 [details]
lsmod
Comment 4 Didier 2003-06-07 09:09:31 EDT
Created attachment 92232 [details]
OOPS from /var/log/messages

Jun  7 14:46:16   : physically attach IEEE1394/Firewire cable
Jun  7 14:46:36   : run detection script

Hardware : IBM ThinkPad A30p
Comment 5 Didier 2003-06-07 09:13:12 EDT
Output of dmesg |grep 1394 :

[root@localhost root]# dmesg |grep 1394
ieee1394: Device added: Node[02:1023]  GUID[0010b92000896e9e]  [Maxtor]
ieee1394: sbp2: Logged into SBP-2 device
ieee1394: sbp2: sbp2_set_busy_timeout error
ieee1394: sbp2: hpsb_send_packet failed
ieee1394: sbp2: Node[01:1023]: Max speed [S400] - Max payload [2048]
ieee1394: sbp2: Error logging into SBP-2 device - login timed-out
ieee1394: sbp2: sbp2_login_device failed
ieee1394: Host removed: Node[00:1023]  GUID[00061b0201004339]  [Linux OHCI-1394]
ieee1394: Device removed: Node[01:1023]  GUID[00027a0b45000959]  [SONY    ]
scsi1 : IEEE-1394 SBP-2 protocol driver (host: <NULL>)
ieee1394: sbp2: hpsb_send_packet failed
ieee1394: sbp2: Logged out of SBP-2 device
ieee1394: Device removed: Node[02:1023]  GUID[0010b92000896e9e]  [Maxtor]
sbp2 ieee1394 ntfs i810_audio ac97_codec soundcore radeon agpgart binfmt_misc
vmnet vmmon parport_pc lp parport autofs ds yenta_socket pcmcia_core orinoco_pci
 <3>ieee1394: sbp2: aborting sbp2 command
sbp2 ieee1394 ntfs i810_audio ac97_codec soundcore radeon agpgart binfmt_misc
vmnet vmmon parport_pc lp parport autofs ds yenta_socket pcmcia_core orinoco_pci

Comment 6 Didier 2003-06-08 10:54:36 EDT
Related to bug #97001 ?
Comment 7 Didier 2003-06-09 07:16:34 EDT
I replaced the 2.4.20-18.9 ieee1394 driver source tree with the tarball from
ieee1394-CVS (2.4 branch :
http://www.linux1394.org/viewcvs/ieee1394/branches/linux-2.4/ ), which I believe
is incorporated in the 2.4.21-rc series.

Compilation with this script :
# --- start
cd /usr/src/linux-2.4
make mrproper
cp configs/kernel-2.4.20-i686.config .config

vi .config
make oldconfig
vi Makefile

make dep
make modules SUBDIRS="drivers/ieee1394"
rm -f /lib/modules/2.4.20-18.9/kernel/drivers/ieee1394/*
cp drivers/ieee1394/*.o /lib/modules/2.4.20-18.9/kernel/drivers/ieee1394
chmod 0644 /lib/modules/2.4.20-18.9/kernel/drivers/ieee1394/*
depmod -a
# --- stop

Compilation runs flawlessly ; unfortunately, 'depmod -a' yields unresolved
symbols in  hosts.o , and 'modprobe ohci1394' yields an error about circular
dependencies.


Comment 8 Didier 2003-07-25 07:27:19 EDT
As discussed in thread
http://lists.insecure.org/lists/linux-kernel/2003/Jul/1833.html ?
Comment 9 Didier 2004-01-29 08:03:42 EST
Upgraded to 2.6.1 ; WFM.

Note You need to log in before you can comment on or make changes to this bug.