Bug 969730 - SELinux is preventing /usr/bin/Xorg from getattr, associate access on the shared memory .
SELinux is preventing /usr/bin/Xorg from getattr, associate access on the sha...
Status: CLOSED DUPLICATE of bug 966544
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:b77dacf416e17cee65fcb6f47fb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 01:32 EDT by Moez Roy
Modified: 2013-06-03 15:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 15:11:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-06-02 01:32:36 EDT
Description of problem:
SELinux is preventing /usr/bin/Xorg from getattr, associate access on the shared memory .

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that Xorg should be allowed getattr associate access on the  shm by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep Xorg /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xserver_t:s0-s0:c0.c1023
Target Context                system_u:system_r:initrc_t:s0
Target Objects                 [ shm ]
Source                        Xorg
Source Path                   /usr/bin/Xorg
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           xorg-x11-server-Xorg-1.13.3-3.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-200.fc18.x86_64 #1 SMP Fri
                              May 24 20:10:49 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-31 09:47:30 PDT
Last Seen                     2013-05-31 09:47:30 PDT
Local ID                      3154659f-f6c6-4357-8f85-6861f382d16b

Raw Audit Messages
type=AVC msg=audit(1370018850.315:510): avc:  denied  { getattr associate } for  pid=932 comm="Xorg" key=0  scontext=system_u:system_r:xserver_t:s0-s0:c0.c1023 tcontext=system_u:system_r:initrc_t:s0 tclass=shm


type=SYSCALL msg=audit(1370018850.315:510): arch=x86_64 syscall=shmctl success=yes exit=0 a0=a08011 a1=2 a2=7fff2c6bf4c0 a3=28 items=0 ppid=818 pid=932 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=tty1 comm=Xorg exe=/usr/bin/Xorg subj=system_u:system_r:xserver_t:s0-s0:c0.c1023 key=(null)

Hash: Xorg,xserver_t,initrc_t,shm,getattr,associate

audit2allow

#============= xserver_t ==============
allow xserver_t initrc_t:shm { getattr associate };

audit2allow -R
require {
	type xserver_t;
}

#============= xserver_t ==============
xserver_stream_connect(xserver_t)


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-200.fc18.x86_64
type:           libreport
Comment 1 Moez Roy 2013-06-02 01:56:11 EDT
this computer uses intel graphics
Comment 2 Miroslav Grepl 2013-06-03 15:11:56 EDT

*** This bug has been marked as a duplicate of bug 966544 ***

Note You need to log in before you can comment on or make changes to this bug.