Bug 969785 - [abrt] ghostscript-9.07-3.fc19: ps_get_glyphname_or_cid: Process /usr/bin/gs was killed by signal 11 (SIGSEGV)
[abrt] ghostscript-9.07-3.fc19: ps_get_glyphname_or_cid: Process /usr/bin/gs ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:4d06264e56cdfd00a6600ac9ef4...
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 07:18 EDT by Pratyush Sahay
Modified: 2013-07-20 05:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: ghostscript-9.07-10.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-20 05:37:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (60.82 KB, text/plain)
2013-06-02 07:18 EDT, Pratyush Sahay
no flags Details
File: cgroup (140 bytes, text/plain)
2013-06-02 07:18 EDT, Pratyush Sahay
no flags Details
File: core_backtrace (1.13 KB, text/plain)
2013-06-02 07:19 EDT, Pratyush Sahay
no flags Details
File: dso_list (4.13 KB, text/plain)
2013-06-02 07:19 EDT, Pratyush Sahay
no flags Details
File: environ (2.08 KB, text/plain)
2013-06-02 07:19 EDT, Pratyush Sahay
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-02 07:19 EDT, Pratyush Sahay
no flags Details
File: maps (12.51 KB, text/plain)
2013-06-02 07:19 EDT, Pratyush Sahay
no flags Details
File: open_fds (176 bytes, text/plain)
2013-06-02 07:19 EDT, Pratyush Sahay
no flags Details
File: proc_pid_status (786 bytes, text/plain)
2013-06-02 07:19 EDT, Pratyush Sahay
no flags Details
File: var_log_messages (23.23 KB, text/plain)
2013-06-02 07:19 EDT, Pratyush Sahay
no flags Details
DVI file generated using LaTeX (11.18 KB, application/x-dvi)
2013-07-03 04:19 EDT, Pratyush Sahay
no flags Details
PS file generated using LaTeX (906.78 KB, application/postscript)
2013-07-03 04:20 EDT, Pratyush Sahay
no flags Details
PDF file generated using LaTeX (733.31 KB, application/pdf)
2013-07-03 04:22 EDT, Pratyush Sahay
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Ghostscript 693921 None None None Never

  None (edit)
Description Pratyush Sahay 2013-06-02 07:18:48 EDT
Description of problem:
Copied compiled latex files from another system. Opened the folder, waited for the thumbnails to show up and this crash happened.

Version-Release number of selected component:
ghostscript-9.07-3.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        gs -dNODISPLAY -dNOGC -sSUBSTFONT=NimbusRomNo9L-Medi -q -- /usr/share/texlive/texmf/dvips/gsftopk/render.ps NimbusRomNo9L-Medi ' (/usr/share/texlive/texmf-dist/fonts/enc/dvips/base/8r.enc) run (/usr/share/texlive/texmf-dist/fonts/type1/urw/times/utmb8a.pfb) brun' ' TeXBase1Encoding ReEncodeFont ' 864.000000
crash_function: ps_get_glyphname_or_cid
executable:     /usr/bin/gs
kernel:         3.9.4-300.fc19.i686
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 ps_get_glyphname_or_cid at psi/zfapi.c:1784
 #1 gs_fapi_do_char at base/gxfapi.c:1364
 #2 FAPI_char at psi/zfapi.c:2197
 #3 interp at psi/interp.c:1289
 #4 gs_call_interp at psi/interp.c:501
 #5 gs_interpret at psi/interp.c:459
 #6 gs_main_interpret at psi/imain.c:235
 #7 gs_main_run_string_end at psi/imain.c:609
 #8 gs_main_run_string_with_length at psi/imain.c:567
 #9 gs_main_run_string at psi/imain.c:549
Comment 1 Pratyush Sahay 2013-06-02 07:18:54 EDT
Created attachment 755839 [details]
File: backtrace
Comment 2 Pratyush Sahay 2013-06-02 07:18:58 EDT
Created attachment 755840 [details]
File: cgroup
Comment 3 Pratyush Sahay 2013-06-02 07:19:02 EDT
Created attachment 755841 [details]
File: core_backtrace
Comment 4 Pratyush Sahay 2013-06-02 07:19:05 EDT
Created attachment 755842 [details]
File: dso_list
Comment 5 Pratyush Sahay 2013-06-02 07:19:09 EDT
Created attachment 755843 [details]
File: environ
Comment 6 Pratyush Sahay 2013-06-02 07:19:12 EDT
Created attachment 755844 [details]
File: limits
Comment 7 Pratyush Sahay 2013-06-02 07:19:16 EDT
Created attachment 755845 [details]
File: maps
Comment 8 Pratyush Sahay 2013-06-02 07:19:20 EDT
Created attachment 755846 [details]
File: open_fds
Comment 9 Pratyush Sahay 2013-06-02 07:19:23 EDT
Created attachment 755847 [details]
File: proc_pid_status
Comment 10 Pratyush Sahay 2013-06-02 07:19:27 EDT
Created attachment 755848 [details]
File: var_log_messages
Comment 11 Tim Waugh 2013-06-03 06:51:22 EDT
Could you please attach a file that demonstrates the problem?
Comment 12 Pratyush Sahay 2013-06-03 09:48:48 EDT
Dont know if its related, but am hitting the following SELinux bugs also on the same folders.
https://bugzilla.redhat.com/show_bug.cgi?id=969941
https://bugzilla.redhat.com/show_bug.cgi?id=970119

I think these seem to be happening when nautilus tries to open the thumbnail of the DVI and PDF files compiled from latex, which contain large number of images to create a PDF file in the order of 10MB.
Comment 13 Pratyush Sahay 2013-07-03 04:19:25 EDT
Created attachment 768142 [details]
DVI file generated using LaTeX

DVI file generated using LaTeX
Comment 14 Pratyush Sahay 2013-07-03 04:20:44 EDT
Created attachment 768143 [details]
PS file generated using LaTeX

PS file generated using LaTeX
Comment 15 Pratyush Sahay 2013-07-03 04:22:43 EDT
Created attachment 768144 [details]
PDF file generated using LaTeX

PDF file generated using LaTeX
Comment 16 Tim Waugh 2013-07-04 08:11:58 EDT
Hmm, can't work out which packages need to be installed in order to test this out.
Comment 17 Pratyush Sahay 2013-07-08 03:17:45 EDT
Over and above the basic Fedora installation, i generally install the following packages for using LaTeX

$ sudo yum install texmaker evince-dvi evince-djvu texlive-collection-science texlive-collection-latexrecommended texlive-collection-genericrecommended texlive-collection-fontsrecommended
Comment 18 Tim Waugh 2013-07-08 06:07:02 EDT
Thanks.  Looks like the minimal set is:

texlive-dvips
texlive-gsftopk
texlive-times

and to reproduce it directly in gs:

(echo 10.000000; seq 1 255 | xargs echo) | gs -dNODISPLAY -dNOGC -sSUBSTFONT=NimbusRomNo9L-Medi -q -- /usr/share/texlive/texmf-dist/dvips/gsftopk/render.ps NimbusRomNo9L-Medi ' (/usr/share/texlive/texmf-dist/fonts/enc/dvips/base/8r.enc) run (/usr/share/texlive/texmf-dist/fonts/type1/urw/times/utmb8a.pfb) brun' ' TeXBase1Encoding ReEncodeFont ' 864.000000

(distilled from 'gsftopk ptmb8r 864')
Comment 19 Tim Waugh 2013-07-08 07:37:48 EDT
This was fixed upstream in commit 23e6bd3.
Comment 20 Fedora Update System 2013-07-17 12:29:30 EDT
ghostscript-9.07-10.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ghostscript-9.07-10.fc19
Comment 21 Fedora Update System 2013-07-18 01:47:50 EDT
Package ghostscript-9.07-10.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ghostscript-9.07-10.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13173/ghostscript-9.07-10.fc19
then log in and leave karma (feedback).
Comment 22 Fedora Update System 2013-07-20 05:37:00 EDT
ghostscript-9.07-10.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.