Bug 969788 - [Doc] Doc-Req-650-[RFE] Add ability to pull system entropy from host
[Doc] Doc-Req-650-[RFE] Add ability to pull system entropy from host
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Virtualization_Administration_Guide (Show other bugs)
6.2
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Laura Novich
ecs-bugs
: Documentation, FutureFeature
Depends On: 786407 973003 973416 973871 989641 1001770 1001773
Blocks: 896690 786408 883503
  Show dependency treegraph
 
Reported: 2013-06-02 07:31 EDT by Laura Novich
Modified: 2016-04-26 09:40 EDT (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 786407
Environment:
Last Closed: 2014-10-15 21:03:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 7 Amit Shah 2014-09-24 02:57:38 EDT
In the first paragraph, we need to mention coupling of /dev/hwrng and rngd is a manual step -- ie customers need to do it themselves, via (e.g. "rngd -b -r /dev/hwrng -o /dev/random").

This manual step is NOT needed RHEL 7.1 onwards, but needed in RHEL6 and RHEL7.0.

There is a mention of "Figure 10.15. Random number generator device", should that be removed?

Last para has "Examples of such devices are /dev/random".  Just make it singular instead of plural?

Thanks,
Comment 9 Amos Kong 2014-09-26 00:54:26 EDT
'virtio-rng' and 'virtio-RNG' are all used in this chapter, I prefer the 1st one.


"The virtio-RNG device is available for both Windows and KVM guest virtual machines"

%s/KVM guest/Linux/
The virtio-rng device is available for both Windows and Linux virtual machines.
Comment 10 Amos Kong 2014-09-26 00:56:11 EDT
<source mode='connect' host physical machine='1.2.3.4' service='1234'>

%s/host physical machine/host/

typo?
Comment 17 Amit Shah 2014-09-30 09:32:11 EDT
Just a couple of notes.  We can hot-plug the virtio-rng device as well, so a shutdown isn't the only option, as mentioned in procedure 10.11.

The libvirt backend/model description might need some editing.  I'm busy with other stuff right now so can't do a thorough review of it, asking Peter Krempa if he can do it.  Peter?
Comment 20 Amit Shah 2014-10-06 04:54:25 EDT
2nd para:
> followind
typo

2nd para:
> Refer Note for instuctions on installing the Windows requirements. Unless noted, the followind descriptions are for both Linux and Windows guests virtual and host physical machines.

"guests virtual and host physical machines" doesn't make sense.  Suppose it should be "for both Linux (rather RHEL?) and Windows guest virtual machines".

3rd para:
>  in the /dev/hwrng directory.

/dev/hwrng is a file; not a directory.  I had changed this to read "at the location /dev/hwrng" in the etherpad at http://etherpad.corp.redhat.com/g5KZlqQqGv  why wasn't that incorporated?

Section Note:
> viorng ("VirtIO RNG Device")to be installed.

Missing whitespace after closing parenthesis

The libvirt section still has redundant info.
Comment 22 Amit Shah 2014-10-07 13:07:39 EDT
Not yet to my taste.

(In reply to Amit Shah from comment #20)
> 2nd para:
> > Refer Note for instuctions on installing the Windows requirements. Unless noted, the followind descriptions are for both Linux and Windows guests virtual and host physical machines.
> 
> "guests virtual and host physical machines" doesn't make sense.  Suppose it
> should be "for both Linux (rather RHEL?) and Windows guest virtual machines".

This is still the same.

> The libvirt section still has redundant info.

And the libvirt section still looks the same.

Particularly, there are three bullets in the last para, and they all overlap.  There also is this line:
> "The EGD protocol is a simple protocol that was introduced by the entropy gathering daemon. It is a substitute for machines that don't support /dev/random. "

This is of no concern to us why the EGD was introduced -- because RHEL always has /dev/random.

We really should scratch the entire "virtio-rng elements" section and re-write it.  Please; I think this is the 5th time I'm mentioning this.
Comment 25 Dayle Parker 2014-10-15 21:03:51 EDT
This change is now available in the Red Hat Enterprise Linux 6.6 documentation at https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/.

Note You need to log in before you can comment on or make changes to this bug.