Bug 969792 - "cinder rename" allows execution without new display-name or new display-description
"cinder rename" allows execution without new display-name or new display-desc...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-cinderclient (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity low
: beta
: 4.0
Assigned To: Eric Harney
Yogev Rabl
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 07:43 EDT by Daniel Paikov
Modified: 2016-04-27 00:18 EDT (History)
7 users (show)

See Also:
Fixed In Version: python-cinderclient-1.0.6-1.el6ost
Doc Type: Bug Fix
Doc Text:
Prior to this update, the 'cinder rename' command would not return any output when run with insufficient arguments. This update addresses this usability issue by advising the user to supply additional arguments when 'cinder rename' is run.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:04:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 40891 None None None Never

  None (edit)
Description Daniel Paikov 2013-06-02 07:43:01 EDT
"cinder rename" command allows running it without new display-name or new display-description. This basically does nothing and produces no output:

[root@orange-vdsf ~(keystone_admin)]# cinder rename d7565525-1816-4c31-ac17-28e3f4f7a17c
[root@orange-vdsf ~(keystone_admin)]#
Comment 5 Yogev Rabl 2013-11-04 04:15:08 EST
verified 

version:
openstack-utils-2013.2-1.el6ost.noarch
openstack-cinder-2013.2-1.el6ost.noarch
Comment 8 errata-xmlrpc 2013-12-19 19:04:01 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.