Bug 969795 - [abrt] systemd-204-3.fc19: crash: Process /usr/lib/systemd/systemd was killed by signal 11 (SIGSEGV)
[abrt] systemd-204-3.fc19: crash: Process /usr/lib/systemd/systemd was killed...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
abrt_hash:53a3e6d3b4bcd4b584723abc772...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 07:54 EDT by Felix Riemann
Modified: 2014-08-08 04:40 EDT (History)
8 users (show)

See Also:
Fixed In Version: systemd-204-20.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-08 04:40:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (6.73 KB, text/plain)
2013-06-02 07:54 EDT, Felix Riemann
no flags Details
File: cgroup (122 bytes, text/plain)
2013-06-02 07:54 EDT, Felix Riemann
no flags Details
File: core_backtrace (880 bytes, text/plain)
2013-06-02 07:54 EDT, Felix Riemann
no flags Details
File: dso_list (1.86 KB, text/plain)
2013-06-02 07:54 EDT, Felix Riemann
no flags Details
File: environ (158 bytes, text/plain)
2013-06-02 07:54 EDT, Felix Riemann
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-02 07:54 EDT, Felix Riemann
no flags Details
File: maps (8.97 KB, text/plain)
2013-06-02 07:54 EDT, Felix Riemann
no flags Details
File: open_fds (2.38 KB, text/plain)
2013-06-02 07:54 EDT, Felix Riemann
no flags Details
File: proc_pid_status (892 bytes, text/plain)
2013-06-02 07:54 EDT, Felix Riemann
no flags Details
File: var_log_messages (2.76 KB, text/plain)
2013-06-02 07:54 EDT, Felix Riemann
no flags Details

  None (edit)
Description Felix Riemann 2013-06-02 07:54:03 EDT
Description of problem:
Didn't do anything particular. I was away from my system and spotted the crash on the lock screen after returning.

Version-Release number of selected component:
systemd-204-3.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/lib/systemd/systemd --system --deserialize 44
crash_function: crash
executable:     /usr/lib/systemd/systemd
kernel:         3.9.4-300.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
Thread no. 1 (6 frames)
 #1 crash at src/core/main.c:142
 #3 rewind at rewind.c:35
 #4 swap_load_proc_swaps at src/core/swap.c:1050
 #5 swap_fd_event at src/core/swap.c:1108
 #6 swap_dispatch_reload at src/core/swap.c:1098
 #7 manager_loop at src/core/manager.c:1732
Comment 1 Felix Riemann 2013-06-02 07:54:08 EDT
Created attachment 755860 [details]
File: backtrace
Comment 2 Felix Riemann 2013-06-02 07:54:13 EDT
Created attachment 755861 [details]
File: cgroup
Comment 3 Felix Riemann 2013-06-02 07:54:17 EDT
Created attachment 755862 [details]
File: core_backtrace
Comment 4 Felix Riemann 2013-06-02 07:54:21 EDT
Created attachment 755863 [details]
File: dso_list
Comment 5 Felix Riemann 2013-06-02 07:54:26 EDT
Created attachment 755864 [details]
File: environ
Comment 6 Felix Riemann 2013-06-02 07:54:30 EDT
Created attachment 755865 [details]
File: limits
Comment 7 Felix Riemann 2013-06-02 07:54:34 EDT
Created attachment 755866 [details]
File: maps
Comment 8 Felix Riemann 2013-06-02 07:54:39 EDT
Created attachment 755867 [details]
File: open_fds
Comment 9 Felix Riemann 2013-06-02 07:54:43 EDT
Created attachment 755868 [details]
File: proc_pid_status
Comment 10 Felix Riemann 2013-06-02 07:54:48 EDT
Created attachment 755869 [details]
File: var_log_messages
Comment 11 Zbigniew Jędrzejewski-Szmek 2014-01-12 16:01:09 EST
This seems to be fixed independently in git. I prepared a patch for F20 and F19 that will go out in the next update.
Comment 12 Fedora Update System 2014-07-22 23:55:10 EDT
systemd-204-20.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/systemd-204-20.fc19
Comment 13 Fedora Update System 2014-07-23 23:21:10 EDT
Package systemd-204-20.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-204-20.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8761/systemd-204-20.fc19
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2014-08-08 04:40:47 EDT
systemd-204-20.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.