Bug 969805 - FSError: umount failed
FSError: umount failed
Status: CLOSED DUPLICATE of bug 968833
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:4dd8e41383b049a3d43891e027e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 08:46 EDT by Witek Mozga
Modified: 2013-06-07 16:33 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 16:33:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (375.59 KB, text/plain)
2013-06-02 08:47 EDT, Witek Mozga
no flags Details
File: anaconda.log (2.43 KB, text/plain)
2013-06-02 08:47 EDT, Witek Mozga
no flags Details
File: backtrace (1.16 KB, text/plain)
2013-06-02 08:47 EDT, Witek Mozga
no flags Details
File: environ (845 bytes, text/plain)
2013-06-02 08:47 EDT, Witek Mozga
no flags Details
File: ifcfg.log (1.34 KB, text/plain)
2013-06-02 08:47 EDT, Witek Mozga
no flags Details
File: lsblk_output (3.09 KB, text/plain)
2013-06-02 08:47 EDT, Witek Mozga
no flags Details
File: messages (157.23 KB, text/plain)
2013-06-02 08:47 EDT, Witek Mozga
no flags Details
File: nmcli_dev_list (5.98 KB, text/plain)
2013-06-02 08:47 EDT, Witek Mozga
no flags Details
File: program.log (41.10 KB, text/plain)
2013-06-02 08:47 EDT, Witek Mozga
no flags Details
File: storage.log (178.37 KB, text/plain)
2013-06-02 08:47 EDT, Witek Mozga
no flags Details

  None (edit)
Description Witek Mozga 2013-06-02 08:46:57 EDT
Description of problem:
I tried to install LXDE version from LiveUSB and anaconda crashed
The following was filed automatically by anaconda:
anaconda 19.30-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 626, in unmount
    raise FSError("umount failed")
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 792, in teardown
    return self.unmount(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 745, in _preTeardown
    self.format.teardown()
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 757, in teardown
    if not self._preTeardown(recursive=recursive):
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 2786, in findExistingInstallations
    device.teardown(recursive=True)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 420, in reset
    self.roots = findExistingInstallations(self.devicetree)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 140, in storageInitialize
    storage.reset()
  File "/usr/lib/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
FSError: umount failed

Version-Release number of selected component:
anaconda-19.30-1.fc19.i686

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-LXDE-i686-19-Beta-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.i686
other involved packages: python-blivet-0.14-1.fc19.noarch, python-libs-2.7.4-4.fc19.i686
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 140, in storageInitialize
    storage.reset()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 420, in reset
    self.roots = findExistingInstallations(self.devicetree)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 2786, in findExistingInstallations
    device.teardown(recursive=True)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 757, in teardown
    if not self._preTeardown(recursive=recursive):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 745, in _preTeardown
    self.format.teardown()
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 792, in teardown
    return self.unmount(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 626, in unmount
    raise FSError("umount failed")
FSError: umount failed
Comment 1 Witek Mozga 2013-06-02 08:47:06 EDT
Created attachment 755884 [details]
File: anaconda-tb
Comment 2 Witek Mozga 2013-06-02 08:47:10 EDT
Created attachment 755885 [details]
File: anaconda.log
Comment 3 Witek Mozga 2013-06-02 08:47:14 EDT
Created attachment 755886 [details]
File: backtrace
Comment 4 Witek Mozga 2013-06-02 08:47:18 EDT
Created attachment 755888 [details]
File: environ
Comment 5 Witek Mozga 2013-06-02 08:47:22 EDT
Created attachment 755889 [details]
File: ifcfg.log
Comment 6 Witek Mozga 2013-06-02 08:47:26 EDT
Created attachment 755890 [details]
File: lsblk_output
Comment 7 Witek Mozga 2013-06-02 08:47:30 EDT
Created attachment 755891 [details]
File: messages
Comment 8 Witek Mozga 2013-06-02 08:47:34 EDT
Created attachment 755892 [details]
File: nmcli_dev_list
Comment 9 Witek Mozga 2013-06-02 08:47:39 EDT
Created attachment 755893 [details]
File: program.log
Comment 10 Witek Mozga 2013-06-02 08:47:43 EDT
Created attachment 755894 [details]
File: storage.log
Comment 11 Witek Mozga 2013-06-02 08:51:32 EDT
It happened when I tried to install Beta Mate version from LiveUSB. The same situation happened when I tried LXDE Beta fromLiveUSB on another laptop.
Comment 12 Adam Williamson 2013-06-07 16:30:22 EDT
I see this in program.log:

02:39:30,232 INFO program: Running... umount /mnt/sysimage
02:39:30,248 INFO program: umount: /mnt/sysimage: target is busy.
02:39:30,251 INFO program:         (In some cases useful info about processes that use
02:39:30,253 INFO program:          the device is found by lsof(8) or fuser(1))

not sure what's going on there.
Comment 13 Adam Williamson 2013-06-07 16:33:09 EDT

*** This bug has been marked as a duplicate of bug 968833 ***

Note You need to log in before you can comment on or make changes to this bug.