Bug 969826 - iSCSI Discover Action example contains redundant info
iSCSI Discover Action example contains redundant info
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: doc-REST_API_Guide (Show other bugs)
3.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.4.0
Assigned To: Andrew Burden
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 11:18 EDT by Alissa
Modified: 2014-03-31 08:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: ovirt-3.4.0-ga
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-31 08:32:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alissa 2013-06-02 11:18:07 EDT
Section Number and Name: 
13.7.7. Host iSCSI Discover Action
Example 13.23. Action to query a list of LUNs for iSCSI portal

Describe the issue: 
part of the example is not correct and should be removed

Suggestions for improvement: 

Additional information: 
Currently the example looks like this:
******START*************
POST /api/hosts/2ab5e1da-b726-4274-bbf7-0a42b16a0fc3/iscsidiscover HTTP/1.1
Accept: application/xml
Content-Type: application/xml

<action>
    <iscsi>
        <address>mysan.example.com</address>
    </iscsi>
</action>

HTTP/1.1 202 Accept
Content-Type: application/xml

<action id="e9126d04-0f74-4e1a-9139-13f11fcbb4ab"
  href="/api/hosts/2ab5e1da-b726-4274-bbf7-0a42b16a0fc3/iscsidiscover/
  e9126d04-0f74-4e1a-9139-13f11fcbb4ab">
    <iscsi_target>iqn.2009-08.com.example:mysan.foobar</iscsi_target>
    ...
<action>
******END*************

The section that starts with HTTP/1.1 202 Accept (from the middle of the example) and till the end of the example (till <action> )
is not correct - it should not be part of the example, and should be removed.
So the example in documentation should contain only:

POST /api/hosts/2ab5e1da-b726-4274-bbf7-0a42b16a0fc3/iscsidiscover HTTP/1.1
Accept: application/xml
Content-Type: application/xml

<action>
    <iscsi>
        <address>mysan.example.com</address>
    </iscsi>
</action>
Comment 1 Andrew Burden 2013-06-11 10:09:45 EDT
Thanks for that.
This change was made as suggested and can be viewed at:
http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Enterprise_Virtualization/3.2/html/Developer_Guide/Host_iSCSI_Discover_Action.html
Comment 3 Itamar Heim 2014-01-12 03:43:08 EST
setting target release to current version for consideration and review. please do not push non-RFE bugs to an undefined target release to make sure bugs are reviewed for relevancy, fix, closure, etc.
Comment 4 Sandro Bonazzola 2014-03-31 08:32:46 EDT
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released

Note You need to log in before you can comment on or make changes to this bug.