Bug 969842 - [abrt] evolution-data-server-3.6.4-4.fc18: g_thread_new: Process /usr/libexec/evolution-calendar-factory was killed by signal 5 (SIGTRAP)
Summary: [abrt] evolution-data-server-3.6.4-4.fc18: g_thread_new: Process /usr/libexec...
Status: CLOSED DUPLICATE of bug 963892
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server   
(Show other bugs)
Version: 18
Hardware: x86_64 Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:cd4e02fa36cb5ec9629d2ba14d5...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-02 16:39 UTC by hx
Modified: 2013-06-03 10:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 10:44:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (43.02 KB, text/plain)
2013-06-02 16:39 UTC, hx
no flags Details
File: cgroup (130 bytes, text/plain)
2013-06-02 16:39 UTC, hx
no flags Details
File: core_backtrace (3.04 KB, text/plain)
2013-06-02 16:39 UTC, hx
no flags Details
File: dso_list (14.88 KB, text/plain)
2013-06-02 16:39 UTC, hx
no flags Details
File: environ (1.11 KB, text/plain)
2013-06-02 16:39 UTC, hx
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-02 16:40 UTC, hx
no flags Details
File: maps (71.07 KB, text/plain)
2013-06-02 16:40 UTC, hx
no flags Details
File: open_fds (685 bytes, text/plain)
2013-06-02 16:40 UTC, hx
no flags Details
File: proc_pid_status (937 bytes, text/plain)
2013-06-02 16:40 UTC, hx
no flags Details
File: var_log_messages (278 bytes, text/plain)
2013-06-02 16:40 UTC, hx
no flags Details

Description hx 2013-06-02 16:39:42 UTC
Version-Release number of selected component:
evolution-data-server-3.6.4-4.fc18

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-calendar-factory
crash_function: g_thread_new
executable:     /usr/libexec/evolution-calendar-factory
kernel:         3.9.4-200.fc18.x86_64
runlevel:       N 5
uid:            1000
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 g_thread_new at gthread.c:838
 #3 impl_DataCalView_stop at e-data-cal-view.c:508
 #4 e_gdbus_marshallers_BOOLEAN__OBJECT at e-gdbus-marshallers.c:124
 #9 e_gdbus_stub_handle_method_call at e-gdbus-templates.c:679
 #10 call_in_idle_cb at gdbusconnection.c:4737
 #15 dbus_server_run_server at e-dbus-server.c:222
 #16 ffi_call_unix64 at ../src/x86/unix64.S:75
 #17 ffi_call at ../src/x86/ffi64.c:486
 #18 g_cclosure_marshal_generic_va at gclosure.c:1550
 #19 _g_closure_invoke_va at gclosure.c:840

Comment 1 hx 2013-06-02 16:39:47 UTC
Created attachment 756006 [details]
File: backtrace

Comment 2 hx 2013-06-02 16:39:49 UTC
Created attachment 756007 [details]
File: cgroup

Comment 3 hx 2013-06-02 16:39:52 UTC
Created attachment 756008 [details]
File: core_backtrace

Comment 4 hx 2013-06-02 16:39:56 UTC
Created attachment 756009 [details]
File: dso_list

Comment 5 hx 2013-06-02 16:39:59 UTC
Created attachment 756010 [details]
File: environ

Comment 6 hx 2013-06-02 16:40:02 UTC
Created attachment 756011 [details]
File: limits

Comment 7 hx 2013-06-02 16:40:06 UTC
Created attachment 756012 [details]
File: maps

Comment 8 hx 2013-06-02 16:40:10 UTC
Created attachment 756013 [details]
File: open_fds

Comment 9 hx 2013-06-02 16:40:13 UTC
Created attachment 756014 [details]
File: proc_pid_status

Comment 10 hx 2013-06-02 16:40:16 UTC
Created attachment 756015 [details]
File: var_log_messages

Comment 11 Milan Crha 2013-06-03 10:44:29 UTC
Thanks for a bug report. The crash was caused when creating a new thread, which failed with an error:
> creating thread '': Error creating thread: Resource temporarily unavailable

There was filled similar bug report already, thus I'm marking this as a duplicate of it. Please see comments there for possible workaround.

*** This bug has been marked as a duplicate of bug 963892 ***


Note You need to log in before you can comment on or make changes to this bug.