Bug 969847 - Editing in the preëdit of ibus-typing-booster behaves weird, especially with transliteration
Editing in the preëdit of ibus-typing-booster behaves weird, especially with ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-typing-booster (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike FABIAN
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 13:15 EDT by Mike FABIAN
Modified: 2013-06-13 02:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: ibus-typing-booster-0.0.32-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 01:54:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
weird-behaviour-of-preedit-in-ibus-typing-booster.ogv (384.29 KB, video/ogg)
2013-06-02 13:15 EDT, Mike FABIAN
no flags Details

  None (edit)
Description Mike FABIAN 2013-06-02 13:15:46 EDT
Created attachment 756043 [details]
weird-behaviour-of-preedit-in-ibus-typing-booster.ogv

$ rpm -q ibus-typing-booster
ibus-typing-booster-0.0.31-1.fc18.noarch
mfabian@ari:~
$ 

Typed chars     Visible in preëdit
g               g
r               gr
u               gru
"               grü
n               grün
BACKSPACE       grü
BACKSPACE       gr
BACKSPACE       g
a               gra

See attached video.

The problem is, that characters are removed inconsistently from the
input buffer and the transliterated string in the preëdit.  I.e.  the
3 times BACKSPACE removed the “rün” from the preëdit, but “u"n”
was removed from the typed chars, leaving “gr” in the list of typed
chars. Then, when typing the final “a”, the “r” from the list of
typed chars comes back into the preëdit.

Leads to very confusing and inconsistent behaviour which depends on
length differences in the input and the transliteration.

On top of that, there is code for handling arrow left, arrow right,
delete, control arrow left, ... but all these do nothing useful
currently in the preëdit, some of them just cause error messages to
appear in the debug log file.
Comment 1 Fedora Update System 2013-06-02 17:58:18 EDT
ibus-typing-booster-0.0.32-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.32-1.fc19
Comment 2 Fedora Update System 2013-06-02 18:00:35 EDT
ibus-typing-booster-0.0.32-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.32-1.fc17
Comment 3 Fedora Update System 2013-06-02 18:02:03 EDT
ibus-typing-booster-0.0.32-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.32-1.fc18
Comment 4 Fedora Update System 2013-06-03 10:42:31 EDT
Package ibus-typing-booster-0.0.32-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-typing-booster-0.0.32-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9919/ibus-typing-booster-0.0.32-1.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-06-13 01:54:58 EDT
ibus-typing-booster-0.0.32-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2013-06-13 02:06:30 EDT
ibus-typing-booster-0.0.32-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2013-06-13 02:35:54 EDT
ibus-typing-booster-0.0.32-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.