Bug 969855 - NetworkManager-openconnect
NetworkManager-openconnect
Status: CLOSED DUPLICATE of bug 980467
Product: Fedora
Classification: Fedora
Component: openconnect (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 14:27 EDT by Michael Greenberg
Modified: 2013-07-10 04:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-10 04:22:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Greenberg 2013-06-02 14:27:50 EDT
Description of problem:
In Fedora 19 beta, after using the /usr/libexec/nm-openconnect-auth-dialog to successfully log into the VPN, NetworkManager does not show the slider button for the connection as "ON".

This is a regression from Fedora 18, where the slider button showed "ON" after a successful connection.

As well, clicking on the ON/OFF slider after the connection has been made, disconnects the connection, and attempts to start a new connection. In Fedora 18, it just disconnected the connection.


Version-Release number of selected component (if applicable):

openconnect-4.99-1.fc19.x86_64
NetworkManager-openconnect-0.9.7.0-2.git20120918.fc19.x86_64


How reproducible:
Connect to a VPN server.


Steps to Reproduce:
1.Connect to a VPN server.
2.Check the NetworkManager pull-down menu of all the network connections
3.The status of the connected VPN will be "OFF" rather than "ON"

Actual results:


Expected results:


Additional info:
Comment 1 David Woodhouse 2013-07-10 04:22:24 EDT

*** This bug has been marked as a duplicate of bug 980467 ***
Comment 2 David Woodhouse 2013-07-10 04:34:45 EDT
Apologies for not looking at this sooner. I'd actually discovered the same issue and filed it against gnome-shell (which I think is where the problem is) myself. I've marked this as a duplicate of that bug, although this one was here first.

Note You need to log in before you can comment on or make changes to this bug.