Bug 969857 - "samba-doc" is missing. No documentation in "samba-swat".
"samba-doc" is missing. No documentation in "samba-swat".
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: samba4 (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Schneider
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 14:33 EDT by Bjoern Rasmussen
Modified: 2013-06-03 13:09 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 08:11:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bjoern Rasmussen 2013-06-02 14:33:34 EDT
Description of problem: "samba-doc" is missing. No documentation in "samba-swat".


Version-Release number of selected component (if applicable):samba-swat-4.0.5-1.fc18.x86_64


How reproducible: Always


Steps to Reproduce:
1. Open "http://localhost:901"!
2. Click any "Help"-link!
3.

Actual results: "404 File Not Found"


Expected results: Help-pages


Additional info:

The discontinued samba-doc packet, would be accessible from http://localhost:901/swat/help/manpages. This directory is almost empty now. A file (/usr/share/samba/swat/help/welcome-no-samba-doc.html) says "Welcome to SWAT! More documentation is available at this point if you install the samba-doc package." But this package is not available any more.

You could argue that this is not a bug, because the samba-swat package does not technically rely on samba-doc. I think it should, because swat is not usable without it. Maybe samba-specialists wouldn't miss it, but they don't use swat anyway.
Comment 1 Andreas Schneider 2013-06-03 08:11:37 EDT
I'm sorry to inform you that SWAT will be discontinued. Due to the maintenance burdern of SWAT and as it is unmaintained we decided to remove it completely. It will not be available in Fedora 19 anymore. Sorry :)

Please use

man smb.conf
Comment 2 Bjoern Rasmussen 2013-06-03 13:09:14 EDT
That's ok Andreas! It's better to remove a package that doesn't work properly, than keep it. Since Samba has become so complex, it's better to configure the smb.conf file directly anyway.

Note You need to log in before you can comment on or make changes to this bug.