Bug 969867 - btrfs-progs does not support raid5 or raid6 - Fedora 18 and Fedora 19
btrfs-progs does not support raid5 or raid6 - Fedora 18 and Fedora 19
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: btrfs-progs (Show other bugs)
19
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Josef Bacik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 15:50 EDT by Gerald Cox
Modified: 2013-09-29 20:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: btrfs-progs-0.20.rc1.20130917git194aa4a-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-29 20:38:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Cox 2013-06-02 15:50:34 EDT
Description of problem:

The version of btrfs-progs in the F18 / F19 repositories does not support raid5 or raid6 even though the current kernel-3.9.4-200.fc18.x86_64 which is the production repositories contains btrfs raid5/raid6 support.

Version-Release number of selected component (if applicable):
btrfs-progs-0.20.rc1.20121017git91d9eec-3.fc18.x86_64.rpm

How reproducible:
Issue mkfs.btrfs -m raid6 -d raid6

Steps to Reproduce:
1.mkfs.btrfs -m raid6 -d raid6

Actual results:
Error that raid6 is not a valid option

Expected results:
command completes successfully

Additional info:
I was able to find a version which supports raid6 in rawhide:
btrfs-progs-0.20.rc1.20130501git7854c8b-3.fc20.x86_64

I understand btrfs is "experimental" - however btrfs-progs should at a minimum support the functions which are provided in the mainstream kernel.  Since the kernel now supports btrfs raid5/raid6, btrfs-progs should be kept current to allow usage of that function.
Comment 1 Eric Sandeen 2013-06-03 12:09:19 EDT
"btrfs-progs should be kept current to allow usage of that function."

s/usage/testing/ :)

btrfs-progs hasn't had a point release upstream for ages (years?) so we can only do a best-effort approach, pushing random upstream git snapshots into fedora.

Since upstream btrfs-progs never stabilizes, it's hard to know when an appropriate time to update might be, or whether it ever makes sense to push updates to older fedoras.  (when the new raid code landed it was very new & untested; how much risk we want to foist onto Fedora users is an open question).

FWIW, I updated btrfs-progs in rawhide in the beginning of may, and that probably has the raid code in it.
Comment 2 Gerald Cox 2013-06-04 23:44:19 EDT
Yes, the version in rawhide has the code to allow use of raid5/6.  My point was that the raid 5/6 support is included in the 3.9 kernel - Fedora 18 is now at 3.9.4 so everyone is being exposed to that code. btrfs-progs allows people to use it if they choose.  I think it makes sense to push the updates to support the functionality which is included in the current kernel, updating btrfs-progs isn't going to affect anyone who isn't using btrfs.
Comment 3 Eric Sandeen 2013-06-05 12:08:53 EDT
My personal POV here (and Zach or Josef can chime in if they want) is that pushing a bleeding edge git snapshot to F18 so that a few people can experiment with new raid code raises unknown risks for F18 users who are happily doing simpler things with their btrfs filesystems, possibly using it for something besides just testing.

If upstream had any sense of stable release points it'd be much less of a worry, but I've given up pretty much all hope of that.

So dumping a new git snapshot on older stable releases raises concerns for me.

Put another way:  If you want to play with bleeding edge btrfs features, rawhide is probably the better place to do it, IMHO.

I'm just trying to be a bit cautious here...
Comment 4 Gerald Cox 2013-06-05 17:33:43 EDT
Eric, I respect your opinion and very much appreciate the fact that it is at least available in rawhide to download.  Thanks for that.  However, I respectfully disagree with your opinion.  

Here is my opinion... BTRFS is by definition experimental.  Anyone using it receives the warning message that it is in fact experimental.  The wiki plainly says it is under heavy development.  While you point out that the new code may introduce risk, you aren't giving adequate weight to the fact that it is also fixing issues and allowing use of features which are now in the F18 kernel.

Let me repeat, because I don't think you are getting that point.  The Fedora 18 kernel:  kernel-3.9.4-200.fc18.x86_64 has the support for raid 5/6.  It is already there...but you need the associated btrfs-progs to be able to use it.

My point is that if Fedora is shipping the kernel in the Fedora 18 repository, NOT rawhide then it is reasonable to believe that one should be able to use those features and not have to search for them in rawhide.

The whole point of BTRFS at this point is to test the features.  There is no BTRFS production at this point... it is all experimental and under heavy development. 

Your comment about "dumping a new git snapshot on older stable releases" I don't think is correct.  First, I'm not asking you to add it to F17 - but since F18 is shipping the kernel which supports the features, it should have the code.  Also, again, by definition, btrfs-progs isn't stable, it is experimental, under heavy development - and while you think the new code may cause issues, it is just as likely at this point to be solving serious issues.
Comment 5 Eric Sandeen 2013-06-05 17:44:33 EDT
Thanks for repeating your point, but I do get it.  I understand that F18 now has the highly experimental and unstable raid code.  My point is that F18 might not be the right place to test bleeding edge btrfs.

But whatever, josef is the maintainer, I'll defer to him.

-Eric
Comment 6 Gerald Cox 2013-06-05 18:03:06 EDT
Thanks Eric for your quick responses, and again I do very much appreciate the fact that the code is available in rawhide.  

As a side note, am very pleased with how simple it was to setup the raid6 array.  Running it on 6 3TB sata drives and so far no errors and been amazed at the performance.  

Running /boot /swap /tmp and /home on EXT4 - I'm brave, but not that brave... LOL...
Comment 7 Fedora Update System 2013-09-18 11:52:08 EDT
btrfs-progs-0.20.rc1.20130917git194aa4a-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/btrfs-progs-0.20.rc1.20130917git194aa4a-1.fc19
Comment 8 Eric Sandeen 2013-09-18 11:52:52 EDT
A new git snapshot of btrfs-progs has been pushed to F19 testing.  If possible, please re-test these bugs & feel free to close or comment as appropriate.

Thanks,
-Eric
Comment 9 Fedora Update System 2013-09-18 22:07:53 EDT
Package btrfs-progs-0.20.rc1.20130917git194aa4a-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing btrfs-progs-0.20.rc1.20130917git194aa4a-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17126/btrfs-progs-0.20.rc1.20130917git194aa4a-1.fc19
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-09-29 20:38:57 EDT
btrfs-progs-0.20.rc1.20130917git194aa4a-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.