Bug 969869 - Multinode nstall fails with "iptables: Resource temporarily unavailable."
Multinode nstall fails with "iptables: Resource temporarily unavailable."
Status: CLOSED WORKSFORME
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
x86_64 Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Ivan Chavero
Nir Magnezi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 16:25 EDT by Britt Houser
Modified: 2014-01-17 06:13 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-17 06:13:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Packstall Install Log (23.85 KB, text/plain)
2013-06-02 16:25 EDT, Britt Houser
no flags Details
IP tables on the controller (2.39 KB, text/plain)
2013-06-02 16:27 EDT, Britt Houser
no flags Details
IP tables on the compute node (1.54 KB, text/plain)
2013-06-02 16:27 EDT, Britt Houser
no flags Details

  None (edit)
Description Britt Houser 2013-06-02 16:25:54 EDT
Created attachment 756082 [details]
Packstall Install Log

Description of problem:
When doing a multi-node install, installer will fail with the error message:

--
ERROR : Error during puppet run : err: /Firewall[001 nova compute incoming]/ensure: change from absent to present failed: Execution of '/sbin/iptables -I INPUT 1 -t filter -p tcp -m multiport --dports 5900:5999 -m comment --comment 001 nova compute incoming -j ACCEPT' returned 4: iptables: Resource temporarily unavailable.
--

On a set of 5 servers, it will fail 2/3 of the time for me.

Version-Release number of selected component (if applicable):

Grizzly-3

How reproducible:

Do a packstack install 

Steps to Reproduce:
1. yum install -q -y http://rdo.fedorapeople.org/openstack/openstack-grizzly/rdo-release-grizzly-3.noarch.rpm
2. yum install -q -y openstack-packstack
3. packstack --install-hosts=172.29.84.71,172.29.84.72,172.29.84.73,172.29.84.74,172.29.84.75

Actual results:

Installer Errors out

Expected results:

Installer completes successfully

Additional info:

A very similar bug was filed and fixed for Folsom: 
https://bugzilla.redhat.com/show_bug.cgi?id=908695

I wonder if those patches just need to be applied to Grizzly?
Comment 1 Britt Houser 2013-06-02 16:27:01 EDT
Created attachment 756083 [details]
IP tables on the controller
Comment 2 Britt Houser 2013-06-02 16:27:33 EDT
Created attachment 756084 [details]
IP tables on the compute node
Comment 3 Britt Houser 2013-06-02 18:47:36 EDT
An easy workaround seems to be just re-run packstack, but this time instead of using --install-hosts= option, give it the --answer-file= option and with the answer file generated by the failed install.
Comment 4 Martin Magr 2014-01-15 06:54:01 EST
Can you please try RDO Havana is the problem still persist? There has been firewall refactor between those two releases. Currently I'm not able to reproduce it neither for Havana nor Grizzly.
Comment 5 Britt Houser 2014-01-16 20:18:54 EST
I won't be able to at this late date.
Comment 6 Martin Magr 2014-01-17 06:13:45 EST
Please reopen this bug or create a new one in case you will hit the same problem. Thanks.

Note You need to log in before you can comment on or make changes to this bug.