Bug 969874 - The entire computer freezes when import and preview video
The entire computer freezes when import and preview video
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: pitivi (Show other bugs)
19
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 16:37 EDT by Bo Lan
Modified: 2013-06-03 14:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 14:39:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bo Lan 2013-06-02 16:37:47 EDT
Description of problem:
When I import a video into the pitivi, the entire computer freezes, not only the x server or anything. Event the CAPS LOCK or NUM light does not work. The CTLR+ALT+F2 does not work. Sometime, I can drag a video into the media library, but when I add it to the time line, the entire computer also freezes.

Version-Release number of selected component (if applicable):
Name        : pitivi
Arch        : noarch
Version     : 0.15.2
Release     : 3.fc19

How reproducible:
everytime

Steps to Reproduce:
1. open pitivi
2. add a new project
3. click the "import file" button
or 
3. drag a video into the "media library", and preview it.

Actual results:
The entire computer dies, and nothing work.

Expected results:
The video can be imported, playback, edited.

Additional info:
Comment 1 Bo Lan 2013-06-02 17:34:33 EDT
There is an additional information. Almost every video non-linear editor, such as kdenlive and openshot, cannot work well in Fedora 19. It seems like a problem of the GNOME or GTK video preview function. I mention pitivi here specifically, because it is the only well-know non-linear editor in fedora repo. If you can reproduce the problem and be sure it is a problem of GNOME and GTK, please reassign it for me.
Comment 2 Gwyn Ciesla 2013-06-03 13:40:41 EDT
Does it matter what type of video you're importing?
Comment 3 Bo Lan 2013-06-03 14:21:48 EDT
(In reply to Jon Ciesla from comment #2)
> Does it matter what type of video you're importing?

My apology, I finally found that it is relevant to what type of graphic card driver I use. It works well after changing to Gallium 0.4 on AMD ARUBA. It probably is a bug of proprietary driver.
Comment 4 Gwyn Ciesla 2013-06-03 14:39:05 EDT
No worries, if you can reproduce it without the proprietary driver, please reopen.

Note You need to log in before you can comment on or make changes to this bug.