Bug 969892 - Regression: SVG Images no longer work in the new UI
Regression: SVG Images no longer work in the new UI
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: REST-API (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: pressgang-ccms-dev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 19:38 EDT by Lee Newson
Modified: 2013-07-01 19:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-01 19:38:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Newson 2013-06-02 19:38:23 EDT
Description of problem:
Try and save any SVG image and notice that it no longer can be saved in the new UI. This used to be possible in the Old UI, so setting this as a regression (see BZ #738922).

How reproducible:
Always

Steps to Reproduce:
1. Find any SVG image and download it.
2. Attempt to upload the SVG to the server.

Actual results:
You get an error message stating: "The image was not uploaded successfully. Make sure that all the images have the same format (i.e they are all JPG, all PNG etc). Otherwise, there may be an error connecting to the server."

Expected results:
The image should be uploaded successfully.

Additional info:
The workaround would be to upload the image directly using the REST API, but that isn't user friendly. This would work as the New UI appears to have no issues displaying SVG images that were uploaded from the Old UI.
Comment 1 Matthew Casperson 2013-06-02 23:42:31 EDT
This looks like an error on the server. It returns an error code of 500, with the text "java.lang.RuntimeException: java.lang.NoSuchMethodError: org.apache.batik.dom.util.HashTableStack.put(Ljava/lang/String;Ljava/lang/String;)Ljava/lang/String;"
Comment 2 Lee Newson 2013-06-02 23:44:20 EDT
Right you are, sorry Matt I should have checked the response message.
Comment 3 Lee Newson 2013-06-03 01:18:25 EDT
This appears to be caused by maven transitive dependency issues from the 1.6-1 version of the batik libraries. Upgrading to 1.7 appears to have fixed these issues, see the dev server for an example.

Note You need to log in before you can comment on or make changes to this bug.