Bug 969927 - Anaconda does not interpret $releasever and $basearch in a repo url in kickstart
Anaconda does not interpret $releasever and $basearch in a repo url in kickstart
Status: CLOSED DUPLICATE of bug 967531
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On: 881911
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-03 01:42 EDT by Larry O'Leary
Modified: 2013-06-03 10:51 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 881911
Environment:
Last Closed: 2013-06-03 10:51:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry O'Leary 2013-06-03 01:42:34 EDT
repo URL is supposed to support $releasever and $basearch in the --baseurl and --mirrorlist parameter starting in Fedora 19 according to http://fedoraproject.org/wiki/Anaconda/Kickstart#repo however this is not the case. When specifying $basearch and/or $releasever in the URL, the repo is ignored.

This was tested on Fedora 19 Beta with the following repo entry:

    repo --name=fedora --cost=10 --mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-$releasever&arch=$basearch

+++ This bug was initially created as a clone of Bug #881911 +++

Anaconda is failing to load a repository because it is sending "$releasever" and "$basearch" instead of interpreting these as variables. I do not recall having this problem in previous releases. 

I am installing Fedora 18 Beta (with anaconda 18.29.2).

I tried the following series of repo lines:

1) The repo:

repo --name=fedora-updates-testing --baseurl=http://mirrors.cs.byu.edu/fedora/updates/testing/$releasever/$basearch

failed to load in anaconda, and the http server gave the error:

File does not exist: /mirrors/fedora/updates/testing/$releasever

2) The repo:

repo --name=fedora-updates-testing --baseurl=http://mirrors.cs.byu.edu/fedora/updates/testing/18/$basearch

failed to load in anaconda, and the http server gave the error:

File does not exist: /mirrors/fedora/updates/testing/18/$basearch

3) Finally, the repo:

repo --name=fedora-updates-testing --baseurl=http://mirrors.cs.byu.edu/fedora/updates/testing/18/x86_64

worked without any errors.

--- Additional comment from Brian C. Lane on 2012-12-05 10:28:49 EST ---

Take a look at how livecd-creator does this, it does some substitutions in imgcreate/yuminst.py
Comment 1 Samantha N. Bueno 2013-06-03 10:51:44 EDT

*** This bug has been marked as a duplicate of bug 967531 ***

Note You need to log in before you can comment on or make changes to this bug.