Bug 969934 - [cmd_task] Cannot search task through distro via command line
Summary: [cmd_task] Cannot search task through distro via command line
Status: CLOSED DUPLICATE of bug 1073280
Alias: None
Product: Beaker
Classification: Community
Component: command line   
(Show other bugs)
Version: 0.12
Hardware: Unspecified Unspecified
medium
medium vote
Target Milestone: ---
Assignee: beaker-dev-list
QA Contact: tools-bugs
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-03 06:11 UTC by Xin Zhang
Modified: 2018-02-06 00:41 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-30 06:05:41 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Xin Zhang 2013-06-03 06:11:06 UTC
Description of problem:
When searching tasks using bkr task-list --distro,there is an error about Attribute.

Version-Release number of selected component (if applicable):
beaker-client-0.12.1-1.git.138.df77d66.el6eng

How reproducible:
always

Steps to Reproduce:
1.bkr task-list --distro Fedora-18

Actual results:
XML-RPC fault: <type 'exceptions.AttributeError'>:'Distro' object has no attribute 'tasks'

Expected results:
Return to a list of tasks whose Distro is Fedora-18

Additional info:

Comment 1 Xin Zhang 2013-06-03 06:26:31 UTC
> Actual results:
> XML-RPC fault: <type 'exceptions.AttributeError'>:'Distro' object has no
> attribute 'tasks'
> 
> This result is for the valid distro name;if the distro name is invalid, the actual results:
> XML-RPC fault: <type 'exceptions.AttributeError'>:'NoneType' object has no attribute 'tasks'

Comment 4 Dan Callaghan 2016-06-30 06:05:41 UTC

*** This bug has been marked as a duplicate of bug 1073280 ***


Note You need to log in before you can comment on or make changes to this bug.