Bug 96994 - second ip address won't start at boot unless the first does
Summary: second ip address won't start at boot unless the first does
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-08 04:33 UTC by Joseph Shraibman
Modified: 2014-03-17 02:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 19:01:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joseph Shraibman 2003-06-08 04:33:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529

Description of problem:
I configured two different ip addresses for my machine.  The problem is that
eth0:1 won't start at boot.  It will start from redhat-config-network itself.

Maybe this component should be initscripts and not redhat-config-network?


Version-Release number of selected component (if applicable):
redhat-config-network-1.2.0-2

How reproducible:
Always

Comment 1 Harald Hoyer 2003-06-10 15:21:02 UTC
Please try:
ftp://people.redhat.com/harald/redhat-config-network/1.2.9-RH9/

Comment 2 Joseph Shraibman 2003-06-10 17:30:36 UTC
That didn't work. What I do a network start after saving the config with that
rechat-config-network this happens:
Bringing up interface home-internal:  Missing config file
../networking/profiles/homedsl/ifcfg-home.
[root@jks-laptop ~]# ls /etc/sysconfig/networking/profiles/homedsl/
hosts  ifcfg-home-external  ifcfg-home-internal  network  resolv.conf

... and after I rebooted and the network didn't come up, I tried to start
redhat-config-network to activate the network again, it caused a kernel panic!

Comment 3 Harald Hoyer 2003-06-11 07:21:19 UTC
$ ls /etc/sysconfig/network-scripts

Comment 4 Joseph Shraibman 2003-06-11 14:48:40 UTC
[root@jks-laptop /home/jks]# ls /etc/sysconfig/network-scripts
ifcfg-eth0      ifdown-isdn   ifup-ippp   ifup-routes
ifcfg-eth0:1    ifdown-post   ifup-ipv6   ifup-sit
ifcfg-lo        ifdown-ppp    ifup-ipx    ifup-sl
ifdown          ifdown-sit    ifup-isdn   ifup-wireless
ifdown-aliases  ifdown-sl     ifup-plip   init.ipv6-global
ifdown-cipcb    ifup          ifup-plusb  network-functions
ifdown-ippp     ifup-aliases  ifup-post   network-functions-ipv6
ifdown-ipv6     ifup-cipcb    ifup-ppp


Comment 5 Harald Hoyer 2003-06-11 15:00:37 UTC
Please try:
ftp://people.redhat.com/harald/redhat-config-network/1.2.10-RH9/

Comment 6 Joseph Shraibman 2003-06-11 15:07:11 UTC
Are you sure this won't cause a kernel panic?

Comment 7 Joseph Shraibman 2003-06-11 15:38:37 UTC
When I ran it I got this message:
Changed the following Nicknames due to the initscripts:
home-external -> home_externalhome-internal -> home_internal

You need a newline in there or something.

/etc/rc.d/init.d/network start seems to work, but stop only brings down the lo
interface.  I'll try actually rebooting the machine now.


Comment 8 Harald Hoyer 2003-06-11 16:08:23 UTC
applications don't cause kernel panics... bad kernel modules do...

Comment 9 Joseph Shraibman 2003-09-15 23:02:13 UTC
OK that worked at the time (guess I forgot to update, sorry) but I since
upgraded my redhat-config-network to 1.2.15-1 and its broken again

Comment 10 Harald Hoyer 2003-09-16 10:37:05 UTC
huh? what is borken?

Comment 11 Joseph Shraibman 2003-09-16 13:08:42 UTC
/etc/rc.d/init.d/network start does not bring up any eth0 interfaces.  It is
supposed to bring up eth0:1.  After I installed the rpm from comment #5 it
worked, but then a while ago I upgraded redhat-config-network to the current
errata version.  Yesterday I changed my config to bring up both eth0 and eth0:1,
then changed it back to bring up only eth0:1, and I'm back to my original problem.

Comment 12 Harald Hoyer 2003-09-16 13:20:29 UTC
hmmm... sounds like an initscripts issue... but can you please attach your current
/etc/sysconfig/network-scripts/ifcfg-eth0
and
/etc/sysconfig/network-scripts/ifcfg-eth0:1


Comment 13 Joseph Shraibman 2003-09-16 13:25:45 UTC
/etc/sysconfig/network-scripts]$ cat ifcfg-eth0\:1
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
GATEWAY=192.168.0.1
TYPE=Ethernet
DEVICE=eth0:1
HWADDR=00:08:02:4c:55:6c
BOOTPROTO=none
NETMASK=255.255.0.0
ONBOOT=yes
IPADDR=192.168.0.2
USERCTL=no
PEERDNS=yes
NETWORK=192.168.0.0
BROADCAST=192.168.255.255


There is no ifcfg-eth0

Comment 14 Harald Hoyer 2003-09-16 13:41:35 UTC
Did you deactive the checkbox in the list? Hmm... you shouldn't do that! Another
consistency check for r-c-n.
Please activate the checkbox and edit eth0. Then _de_select "Activate device
when computer starts".
Edit eth0:1 and make sure: "Activate device when computer starts" is active

Comment 15 Joseph Shraibman 2003-09-16 13:47:09 UTC
I thought I was supposed to uncheck the checkbox.

Anyway I did what you said and it still doesn't work.

Now:

/etc/sysconfig/network-scripts]$ cat ifcfg-eth0
DEVICE=eth0
BOOTPROTO=none
ONBOOT=no
IPADDR=64.36.42.194
NETMASK=255.255.255.248
USERCTL=yes
PEERDNS=no
GATEWAY=' 64.36.42.193'
TYPE=Ethernet
NETWORK=64.36.42.192
BROADCAST=64.36.42.199
/etc/sysconfig/network-scripts]$ cat ifcfg-eth0:1
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
GATEWAY=192.168.0.1
TYPE=Ethernet
DEVICE=eth0:1
HWADDR=00:08:02:4c:55:6c
BOOTPROTO=none
NETMASK=255.255.0.0
ONBOOT=yes
IPADDR=192.168.0.2
USERCTL=no
PEERDNS=yes
NETWORK=192.168.0.0
BROADCAST=192.168.255.255


Comment 16 Harald Hoyer 2003-09-16 13:59:43 UTC
hmm... then the initscripts cannot cope with eth0:1 active and eth0 not?
reassigning to the initscripts... Bill?

Comment 17 Joseph Shraibman 2003-09-16 14:07:30 UTC
Well like I said you had this fixed at one point, but then I upgraded my
redhat-config-network and broke it.

Comment 18 Bill Nottingham 2003-09-16 15:50:03 UTC
Hm, yes, ifcfg-eth0:1 won't be brought up on boot if ifcfg-eth0 isn't brought up
at all. For aliases, if you have one you want to be brought up at all times,
make it the primary address for now.

Comment 19 Joseph Shraibman 2003-10-01 21:16:04 UTC
Now I have the opposite problem.  Both are coming up, when I only want one to. 
The other one has ONBOOT=no but it still starts up

Comment 20 Bill Nottingham 2003-10-01 22:04:30 UTC
For aliases, set ONPARENT={yes,no}. Aliases don't support ONBOOT at the moment.

Comment 21 Joseph Shraibman 2003-10-02 04:02:35 UTC
Shouldn't redhat-config-network take care of that?  Should I file a seperate bug
for that?

Comment 22 Bill Nottingham 2003-10-02 04:05:29 UTC
ONBOOT may be added for aliases in a future release, so maybe not.

Of course, in future-future releases, the specific alias device framework will
probably be deprecated in favor of just adding more IP addresses to devices. But
that's not going to happen in the next month or two. :)

Comment 23 Bill Nottingham 2005-09-30 19:01:14 UTC
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

Realistically, I don't see any issues left here:

- aliases don't operate fully independent of the parent (parent must be up for
any alias to run)
- ONPARENT=(yes|no) is the defined means of changing this.




Note You need to log in before you can comment on or make changes to this bug.