Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
The --prealloc-metadata option for virsh volume commands(vol-clone, vol-create-as, vol-create, vol-create-from) doesn't support raw format image, so commands always fail with error:
error: unsupported flags (0x1) in function virStorageBackendCreateRaw
Version-Release number of selected component (if applicable):
libvirt-1.0.5-2.el7.x86_64
How reproducible:
100%
Steps to Reproduce:
1. Clone or create a raw format vol with --prealloc-metadata option:
# virsh vol-clone vol new-vol default --prealloc-metadata
error: Failed to clone vol from vol
error: unsupported flags (0x1) in function virStorageBackendCreateRaw
or
# virsh vol-create default new-vol.xml --prealloc-metadata
error: Failed to create vol from new-vol.xml
error: unsupported flags (0x1) in function virStorageBackendCreateRaw
Actual results:
As step1.
Expected results:
Improve the error message.
Additional info:
Fixed upstream:
commit 77e7f69c3b88ae0a7364fa88334a483a247d7200
Author: Peter Krempa <pkrempa>
Date: Wed Jun 5 09:38:41 2013 +0200
storage: Provide better error message if metadata pre-alloc is unsupported
Instead of a unknown flag error report that metadata pre-allocation is
not supported with the requested volume creation method.
Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=969982
v1.0.6-27-g77e7f69
Verify with libvirt-1.1.0-1.el7.x86_64.
# virsh vol-clone vol new-vol default --prealloc-metadata
error: Failed to clone vol from vol
error: unsupported configuration: metadata preallocation is not supported for raw volumes
# virsh vol-create default vol-new.xml --prealloc-metadata
error: Failed to create vol from vol-new.xml
error: unsupported configuration: metadata preallocation is not supported for raw volumes
The error message is clear enough, so move bug to VERIFIED.
This request was resolved in Red Hat Enterprise Linux 7.0.
Contact your manager or support representative in case you have further questions about the request.