Bug 969993 - nfs: help does not display performance.nfs.* options [NEEDINFO]
nfs: help does not display performance.nfs.* options
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
medium Severity medium
: ---
: RHGS 3.0.0
Assigned To: Vivek Agarwal
Saurabh
:
Depends On:
Blocks: 1090826
  Show dependency treegraph
 
Reported: 2013-06-03 05:35 EDT by Saurabh
Modified: 2016-02-17 19:03 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.6.0.0-1.el6rhs
Doc Type: Bug Fix
Doc Text:
Previously the command 'gluster volume set help' did not display the configuration options for white-behind performance translator namely - performance.nfs.flush-behind performance.nfs.write-behind-window-size performance.nfs.strict-o-direct performance.nfs.strict-write-ordering With this fix, the options are displayed with description.
Story Points: ---
Clone Of:
: 1090826 (view as bug list)
Environment:
Last Closed: 2014-09-22 15:28:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
psriniva: needinfo? (spradhan)


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-06-03 05:35:13 EDT
Description of problem:
gluster volume set help does not display the options available for nfs performance improvement.

Version-Release number of selected component (if applicable):
glusterfs-3.4.0.8rhs-1.el6rhs.x86_64

How reproducible:
always

Steps to Reproduce:
1. gluster volume set help | grep performance
2.
3.

Actual results:
it does not display any information for nfs performance related stuff.

Expected results:
gluster volume set help | grep performance
displays information about other options not the nfs ones, so altogether the customer will never get to know about the options.

Additional info:
Comment 2 Vivek Agarwal 2014-04-07 07:41:00 EDT
Per bug triage, between dev, PM and QA, moving these out of denali
Comment 4 santosh pradhan 2014-04-24 05:18:50 EDT
Posted the patch for review:

http://review.gluster.org/#/c/7546/
Comment 5 santosh pradhan 2014-04-28 13:57:50 EDT
commit c52ab5eb52519d41b0ae146ec7b1276f2ffae9e9
Author: Santosh Kumar Pradhan <spradhan@redhat.com>
Date:   Thu Apr 24 14:39:20 2014 +0530

    glusterd: Help does not show performance.nfs.* opt
    
    Gluster does not display performance.nfs.* options in help.
    
    In Gluster NFS, write-behind is the only performance xlator
    which gets loaded. Gluster volume set help should display all
    the options provided by write-behind xlator.
    
    Change-Id: I4a41151a6c15eeed8e8d123a6044c6f0c42b56b0
    BUG: 1090826
    Signed-off-by: Santosh Kumar Pradhan <spradhan@redhat.com>
    Reviewed-on: http://review.gluster.org/7546
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 6 Nagaprasad Sathyanarayana 2014-05-06 06:35:03 EDT
BZs not targeted for Denali.
Comment 8 Vivek Agarwal 2014-05-22 07:43:19 EDT
Merged as a part of rebase
Comment 9 Pavithra 2014-08-07 01:51:26 EDT
Hi Santosh,

Please review the edited doc text for technical accuracy and sign off.
Comment 12 errata-xmlrpc 2014-09-22 15:28:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1278.html

Note You need to log in before you can comment on or make changes to this bug.