Bug 969995 - An error occurred executing 'gear postreceive' if trying to install an package which is already installed via channel for php
An error occurred executing 'gear postreceive' if trying to install an packa...
Status: CLOSED WORKSFORME
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified FreeBSD
medium Severity medium
: ---
: ---
Assigned To: Vojtech Vitek
libra bugs
:
Depends On:
Blocks: 1005211
  Show dependency treegraph
 
Reported: 2013-06-03 05:35 EDT by nsun
Modified: 2015-05-14 19:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1005211 (view as bug list)
Environment:
Last Closed: 2013-09-02 12:28:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nsun 2013-06-03 05:35:49 EDT
Description of preblem:
When we have added channel "channel://pear.php.net/Validate-0.8.4" to a php app, then the second time git push will be failed with 'gear postreceive' .

Version-Release number of selected component (if applicable):
devenv_3307
STG(devenv-stage_356)

How reproducible:
aways

Steps to reproduce:
1. Create a php app
# rhc app create php php-5.3 -predhat
2.Write channel to file 'deplist.txt'
# echo 'channel://pear.php.net/Validate-0.8.4' > deplist.txt
3. git push it 
# git commit -am "added channel" ; git push
4. Create new file to this repo and git push
# touch test; git add test; git commit -am "Added new file";git push
Actual results:
...
remote: PHP Stack trace:
remote: PHP   1. {main}() /usr/share/pear/pearcmd.php:0
remote: PHP   2. PEAR_Command_Common->run() /usr/share/pear/pearcmd.php:305
remote: PHP   3. PEAR_Command_Registry->doList() /usr/share/pear/PEAR/Command/Common.php:271
remote: PHP   4. PEAR_Command_Registry->doFileList() /usr/share/pear/PEAR/Command/Registry.php:146
remote: PHP   5. file_exists() /usr/share/pear/PEAR/Command/Registry.php:255
remote: pear/Validate is already installed and is the same as the released version 0.8.4
remote: upgrade failed
remote: An error occurred executing 'gear postreceive'
remote: 
remote: For more details about the problem, try running the command again with the '--trace' option.
To ssh://51ac44796088672b29000001@php1-sun000.osetestv2auto.com/~/git/php1.git/
   5c52c9a..ead0d9e  master -> master

Expect results:
Successed

Additional info:
Comment 1 Xiaoli Tian 2013-06-03 05:49:52 EDT
This error only happens if trying to install the  package which is already installed.
Comment 2 nsun 2013-06-03 06:07:52 EDT
I tried Added 'channel://pear.php.net/Text_Highlighter-0.7.3' to deplist.txt.
Git push again will be ok after Text_Highlighter already installed.
Comment 3 Zhe Wang 2013-06-17 23:48:16 EDT
I was unable to recreate this bug in devenv_3373, and the steps were identical to those in Description.

Results:

remote: downloading Validate-0.8.4.tgz ...
remote: Starting to download Validate-0.8.4.tgz (20,809 bytes)
remote: ........done: 20,809 bytes
remote: downloading Date-1.4.7.tgz ...
remote: Starting to download Date-1.4.7.tgz (55,754 bytes)
remote: ...done: 55,754 bytes
remote: install ok: channel://pear.php.net/Validate-0.8.4
remote: install ok: channel://pear.php.net/Date-1.4.7

However, the warnings still exist.
Comment 4 Vojtech Vitek 2013-09-02 12:28:07 EDT
Agreed with @Zhe Wang, I also couldn't reproduce the issue.

Closing this bz as WORKSFORME. Please, feel free to reopen once you can reproduce the issue.

P.S.: We deal with the PEAR warnings in the separate bug 1000223.

Note You need to log in before you can comment on or make changes to this bug.