This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 970011 - stateless snapshot (Read-Only) is not deleted
Summary: stateless snapshot (Read-Only) is not deleted
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
(Show other bugs)
Version: 3.3.0
Hardware: Unspecified Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-03 10:08 UTC by Jiri Belka
Modified: 2015-09-22 13:09 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 11:23:43 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log, vdsm.log (90.00 KB, application/x-tar)
2013-06-03 10:08 UTC, Jiri Belka
no flags Details

Description Jiri Belka 2013-06-03 10:08:30 UTC
Created attachment 756229 [details]
engine.log, vdsm.log

Description of problem:
We have following scenarion:

* Run a VM stateless (and open its console)
* Stop vdsmd
* Shutdown guest's OS from the guest itself (from console)
* Start vdsmd

When the guest is down and then vdsmd is started again, the stateless snapshot does still exists - it is not deleted.

This state impacts immediate next start of the VM, which fails just because of the existence of the stateless snapshot.

  Failed to start VM jb-wxp, because exist snapshot for stateless state. Snapshot will be deleted.

This failure cleans the snapshot and then everything is OK.

Version-Release number of selected component (if applicable):
sf17.2

How reproducible:
100%

Steps to Reproduce:
1. Run a VM in stateless mode and open its console
2. stop vdsmd
3. shutdown guest's OS from the guest itself (console)
4. start vdsmd
5. check snapshosts list in admin portal

Actual results:
stateless snapshot does still exists for non-running VM

Expected results:
stateless snapshot should not exists for non-started VMs

Additional info:

Comment 1 Dafna Ron 2013-06-03 11:23:43 UTC
closing this as not a bug. 
following bug: https://bugzilla.redhat.com/show_bug.cgi?id=735097
the agreed solution/behaviour is to try and delete the stateless snapshot when vm is started again and to fail run of vm until the stateless snapshot is removed. 
once the snapshot is removed we can start the vm properly.


Note You need to log in before you can comment on or make changes to this bug.