Bug 970072 - Child channel is in incorrect group of parent channels on page "My Channels"
Child channel is in incorrect group of parent channels on page "My Channels"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Korbel
Martin Korbel
: Regression
Depends On:
Blocks: sat560-blockers
  Show dependency treegraph
 
Reported: 2013-06-03 08:22 EDT by Pavel Studeník
Modified: 2013-10-01 17:54 EDT (History)
3 users (show)

See Also:
Fixed In Version: spacewalk-java-1.9.83-44
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:54:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
webui: list of channels (119.98 KB, image/png)
2013-06-03 08:22 EDT, Pavel Studeník
no flags Details
Verification of this bug (80.11 KB, image/png)
2013-06-26 09:25 EDT, Martin Korbel
no flags Details

  None (edit)
Description Pavel Studeník 2013-06-03 08:22:19 EDT
Created attachment 756281 [details]
webui: list of channels

Description of problem:
I created custom parent channel and child channel with parent channel "Redhat Channels". I looked on webUI page ( Channels -> My Channels ). Child channel is NOT in correct group of parent channels.


Version-Release number of selected component (if applicable):
spacewalk-java-1.9.83-40.el6sat.noarch

How reproducible:
1:1 regression (only 5.6)

Steps to Reproduce:
1. create custom parent channel with some child channels
2. create child channel with "Red Hat" parent channel
3. go to page Channels -> My Channels 

Actual results:
Child channels is in incorrect group.

Expected results:
Child channels is in correct group.

Additional info:
I add screenshot webUI.
Comment 4 Tomáš Kašpárek 2013-06-13 04:48:00 EDT
commited fix into spacewalk.git: a3c140947fa6dcc73cff6b00f3417e214a4d6f07
Comment 7 Martin Korbel 2013-06-26 09:25:35 EDT
Created attachment 765579 [details]
Verification of this bug

VERIFIED on spacewalk-java-1.9.83-46.el6sat
Comment 8 Clifford Perry 2013-10-01 17:54:15 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.