Bug 9701 - permissions in /usr/bin/rnews, /var/spool/news/incoming conflict with /etc/cron.daily/inn-cron-rnews
Summary: permissions in /usr/bin/rnews, /var/spool/news/incoming conflict with /etc/cr...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: inn (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-23 02:31 UTC by Jonathan Kamens
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-19 16:35:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2000-02-23 02:31:50 UTC
The file /etc/cron.daily/inn-cron-rnews invokes rnews -U.  However, since
it's in /etc/cron.daily rather than in news' crontab, it runs as root
instead of as news.  That's mostly OK since rnews is setuid news.  What
rnews is *not*, however, is setgid news, and that's a problem, since it
means that once rnews finishes processing a file in
/var/spool/news/incoming, it can't delete it.

Either rnews should be made setgid news, or the rnews -U should be run out
of a news crontab file instead of out of /etc/cron.daily.


Note You need to log in before you can comment on or make changes to this bug.