Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 970138 - Sendmail::PMilter prevents milters from forking and reaping child processes
Sendmail::PMilter prevents milters from forking and reaping child processes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-Sendmail-PMilter (Show other bugs)
18
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-03 10:16 EDT by Jonathan Kamens
Modified: 2013-06-29 14:20 EDT (History)
1 user (show)

See Also:
Fixed In Version: perl-Sendmail-PMilter-1.00-8.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-23 01:53:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to reset SIGCHLD handler in milters (283 bytes, patch)
2013-06-03 10:16 EDT, Jonathan Kamens
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 85826 None None None Never

  None (edit)
Description Jonathan Kamens 2013-06-03 10:16:16 EDT
Created attachment 756319 [details]
patch to reset SIGCHLD handler in milters

I'm filing this bug here since it appears that y'all are doing more to maintain Sendmail::PMilter than its actual maintainers.

In https://rt.cpan.org/Ticket/Display.html?id=85826 , I report that Sendmail::PMilter prevents milters from forking and reaping their own child processes, because it sets a SIGCHLD handler in the parent process and then doesn't remove it in the children.

The fix (attached) is obvious and trivial.

Could you put this in the Fedora RPM?

Thank you.
Comment 1 Fedora Update System 2013-06-13 09:18:35 EDT
perl-Sendmail-PMilter-1.00-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/perl-Sendmail-PMilter-1.00-8.fc19
Comment 2 Fedora Update System 2013-06-13 09:18:51 EDT
perl-Sendmail-PMilter-1.00-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/perl-Sendmail-PMilter-1.00-8.fc18
Comment 3 Fedora Update System 2013-06-13 14:09:16 EDT
Package perl-Sendmail-PMilter-1.00-8.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-Sendmail-PMilter-1.00-8.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10797/perl-Sendmail-PMilter-1.00-8.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-06-23 01:53:58 EDT
perl-Sendmail-PMilter-1.00-8.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2013-06-29 14:20:21 EDT
perl-Sendmail-PMilter-1.00-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.