Bug 970145 - [RFE] Package Eclipse Mylyn Reviews
[RFE] Package Eclipse Mylyn Reviews
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse-mylyn (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-03 10:27 EDT by Roland Grunberg
Modified: 2015-05-04 07:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-04 07:50:45 EDT
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland Grunberg 2013-06-03 10:27:46 EDT
It would be nice to package Eclipse Mylyn Reviews (http://www.eclipse.org/reviews/), and in particular, the Gerrit connector as a subpackage of the eclipse-mylyn srpm. The benefit would be that Eclipse users whose projects use the Gerrit Code Review tool (eg. eclipse.org projects), could now perform their reviews entirely within Eclipse.

Looking at the sources http://git.eclipse.org/c/mylyn/org.eclipse.mylyn.reviews.git/ , it seems like most of the dependencies exist in Fedora already except for : com.google.gerrit (Gerrit code review tool)
Comment 1 Roland Grunberg 2013-06-06 14:28:18 EDT
Looks like we'd still need gwtorm, gwtexpu, gwt-user, gwt-servlet for gerrit-common, gerrit-prettify, gerrit-reviewdb and gerrit-patch-jgit (the main dependencies from gerrit needed for Mylyn Reviews Gerrit Connector).
Comment 2 Roland Grunberg 2013-10-10 12:18:22 EDT
Also see Bug 701316 and Bug 749673 for past work.
Comment 3 Roland Grunberg 2013-10-15 09:48:21 EDT
(Test Comment, Please Ignore)
Comment 5 Alexander Kurtakov 2015-05-04 07:50:45 EDT
Closing. No interest in this work from anybody. If someone interested please reopen and take the bug.

Note You need to log in before you can comment on or make changes to this bug.