Bug 970145 - [RFE] Package Eclipse Mylyn Reviews
Summary: [RFE] Package Eclipse Mylyn Reviews
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-mylyn
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Alexander Kurtakov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-03 14:27 UTC by Roland Grunberg
Modified: 2015-05-04 11:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-04 11:50:45 UTC


Attachments (Terms of Use)

Description Roland Grunberg 2013-06-03 14:27:46 UTC
It would be nice to package Eclipse Mylyn Reviews (http://www.eclipse.org/reviews/), and in particular, the Gerrit connector as a subpackage of the eclipse-mylyn srpm. The benefit would be that Eclipse users whose projects use the Gerrit Code Review tool (eg. eclipse.org projects), could now perform their reviews entirely within Eclipse.

Looking at the sources http://git.eclipse.org/c/mylyn/org.eclipse.mylyn.reviews.git/ , it seems like most of the dependencies exist in Fedora already except for : com.google.gerrit (Gerrit code review tool)

Comment 1 Roland Grunberg 2013-06-06 18:28:18 UTC
Looks like we'd still need gwtorm, gwtexpu, gwt-user, gwt-servlet for gerrit-common, gerrit-prettify, gerrit-reviewdb and gerrit-patch-jgit (the main dependencies from gerrit needed for Mylyn Reviews Gerrit Connector).

Comment 2 Roland Grunberg 2013-10-10 16:18:22 UTC
Also see Bug 701316 and Bug 749673 for past work.

Comment 3 Roland Grunberg 2013-10-15 13:48:21 UTC
(Test Comment, Please Ignore)

Comment 5 Alexander Kurtakov 2015-05-04 11:50:45 UTC
Closing. No interest in this work from anybody. If someone interested please reopen and take the bug.


Note You need to log in before you can comment on or make changes to this bug.