Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 970146 - db-control: verify online-backup should (at least) complain
Summary: db-control: verify online-backup should (at least) complain
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 560
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Matej Kollar
URL:
Whiteboard:
Depends On:
Blocks: sat560-blockers
TreeView+ depends on / blocked
 
Reported: 2013-06-03 14:29 UTC by Matej Kollar
Modified: 2015-07-26 22:21 UTC (History)
1 user (show)

Fixed In Version: spacewalk-web-1.9.22-12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-10-01 21:53:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Matej Kollar 2013-06-03 14:29:34 UTC
Description of problem:

  Running `db-control verify $online_backup_file` prints (on stdout)

    ** Restoring from file $online_backup_file.
    Restoration complete.

  From what I know, we do not support verify on hot-backups.

Version-Release number of selected component (if applicable): 5.6

How reproducible: always/deterministic

Steps to Reproduce:

  mkdir $backupdir
  chmod a+wx $backupdir
  db-control online-backup $backupdir/backup

  # requested by db-control verify
  spacewalk-service --exclude=postgresql stop

  db-control verify $backupdir/backup 2>/dev/null

Actual results:

  ... "** Restoring from file $backupdir/backup.\nRestoration complete.\n"

Expected results:

  Shutting down db probably should not be requested.
  Warning that verifying on-line backups is not supported.
  Exit with non-zero value.

Additional info:

  Differentiation based just on fact that cold-backup is directory
  while hot-backup is file may suffice(?).

Comment 2 Michael Mráka 2013-06-10 12:28:07 UTC
Fixed in spacewalk master by
commit 1879108ffc92e3f9e4847589556b2e2aaf49f433
    970146 - fix db-control examine and verify for online backups

Comment 5 Clifford Perry 2013-10-01 21:53:06 UTC
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html


Note You need to log in before you can comment on or make changes to this bug.