Bug 97015 - XFree86 locks up kernel when choosing color depth > 8
Summary: XFree86 locks up kernel when choosing color depth > 8
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 9
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-08 23:00 UTC by Need Real Name
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 17:01:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config file (3.23 KB, text/plain)
2003-06-08 23:01 UTC, Need Real Name
no flags Details
XFree86 log from attempt at 16 bit color (34.42 KB, text/plain)
2003-06-09 03:15 UTC, Need Real Name
no flags Details

Description Need Real Name 2003-06-08 23:00:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I am using an ATI Rage Pro 128 graphics card. I have a ViewSonic PF790 monitor.
I have tried this under multiple versions of RedHat (7.3, 8, 9). Whenever I
attempt to switch the default color depth in XF86Config to 15, 16, or 24 and run
either X or startx from the command line (in runlevel 3) or use runlevel 5, the
entire kernel locks up. I cannot kill the X server, I cannot switch to a
different console, and I cannot even use the power button on the CPU. Too make
debugging this even more fun, I have not seen any messages in the logs or output
when redirecting that that indicate that any problem has occurred when I get the
system back up.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-2

How reproducible:
Always

Steps to Reproduce:
1. modify XF86Config for DefaultColors = 16
2. startx
3. watch the screen become a mess and be unable to do anything
    

Actual Results:  I cannot do anything and the screen is unreadable.

Expected Results:  I should have seen a normal X screen at with 16 bit color depth.

Additional info:

Comment 1 Need Real Name 2003-06-08 23:01:57 UTC
Created attachment 92266 [details]
XF86Config file

Comment 2 Need Real Name 2003-06-09 03:15:17 UTC
Created attachment 92269 [details]
XFree86 log from attempt at 16 bit color

I had done an XFree86 - configure prior to attempting this. This is the entire
log, I have not edited anything. The only difference where it succeeds (at 8
bit depth) is that XINPUT is not the last line. I still have the one EE line
and the one WW line.

Comment 3 Mike A. Harris 2004-09-01 17:01:39 UTC
Unable to reproduce this on rawhide xorg-x11-6.7.99.903, please
upgrade to newer OS release if this problem still occurs, and test
rawhide xorg-x11.  If the problem persists for you particular
hardware, please file a bug report to the X.Org bugzilla at:
http://bugs.freedesktop.org in the "xorg" component, and we will
track the issue upstream.


Note You need to log in before you can comment on or make changes to this bug.