Bug 97017 - httpd source rpm does not build a binary rpm
Summary: httpd source rpm does not build a binary rpm
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: httpd (Show other bugs)
(Show other bugs)
Version: 9
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-08 23:11 UTC by Isaac-Lew
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-25 16:46:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Isaac-Lew 2003-06-08 23:11:53 UTC
Description of problem:

The updated httpd rpm fails to build.


Version-Release number of selected component (if applicable):

2.0.40-21.3

How reproducible:
Very


Steps to Reproduce:
1. Try rebuilding the httpd-2.0.40-21.3.src.rpm with 'rpmbuild --rebuild
httpd-2.0.40-21.3.src.rpm'
2.
3.
    
Actual results:

Bad exit status from /var/tmp/rpm-tmp.52254 (%install)

Expected results:

Binary httpd rpm(s)

Additional info:
Also failed using 'rpmbuild --rebuild httpd-2.0.40-21.3.src.rpm --target i386'

Comment 1 Isaac-Lew 2003-06-08 23:12:51 UTC
+ install -m 644 /usr/src/redhat/SOURCES/httpd.conf
/var/tmp/httpd-root/usr/etc/httpd/conf/httpd.conf
+ mkdir /var/tmp/httpd-root/usr/etc/httpd/conf/ssl.crl
+ mkdir /var/tmp/httpd-root/usr/etc/httpd/conf/ssl.crt
+ mkdir /var/tmp/httpd-root/usr/etc/httpd/conf/ssl.csr
+ mkdir /var/tmp/httpd-root/usr/etc/httpd/conf/ssl.key
+ mkdir /var/tmp/httpd-root/usr/etc/httpd/conf/ssl.prm
+ install -m 644 /usr/src/redhat/SOURCES/mod_ssl-Makefile.crt
/var/tmp/httpd-root/usr/etc/httpd/conf/ssl.crt/Makefile.crt
+ install -m 644 /usr/src/redhat/SOURCES/mod_ssl-Makefile.crl
/var/tmp/httpd-root/usr/etc/httpd/conf/ssl.crl/Makefile.crl
+ ln -s ../../../usr/share/ssl/certs/Makefile /var/tmp/httpd-root/etc/httpd/conf
ln: creating symbolic link `/var/tmp/httpd-root/etc/httpd/conf' to
`../../../usr/share/ssl/certs/Makefile': No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.52254 (%install)

Comment 2 Joe Orton 2003-06-10 12:08:25 UTC
I couldn't reproduce this.  Are you using a fully updated RHL9 installation?

Comment 3 Isaac-Lew 2003-06-10 17:16:26 UTC
It's been fully patched.  I noticed that the httpd.spec file calls for
$RPM_BUILD_ROOT (which I thought was deprecated), I don't have this variable set
anywhere.  Could that be the cause of the build problem?

Comment 4 Joe Orton 2003-06-19 08:15:33 UTC
What version of RPM are you using? RPM_BUILD_ROOT has been correctly expanded to
/var/tmp/httpd-root in the output you give above.

Are you running rpmbuild as root or as a user?

Comment 5 Joe Orton 2005-01-25 16:46:35 UTC
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.

c) report the bug to the Fedora Legacy project who may wish to
continue maintenance of this package.



Note You need to log in before you can comment on or make changes to this bug.