Bug 970170 - NM Failes to enable/reconnect wired internet after resume from sleep
NM Failes to enable/reconnect wired internet after resume from sleep
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-03 11:11 EDT by Nathanael Noblet
Modified: 2013-06-18 12:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 12:15:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the result of sudo grep NetworkManager /var/log/messages after resume but before manually enabling the network via NM Applet (1.69 KB, text/plain)
2013-06-03 11:11 EDT, Nathanael Noblet
no flags Details
sudo grep NetworkManager /var/log/messages after manually enabling the network via nm-applet (5.30 KB, text/plain)
2013-06-03 11:12 EDT, Nathanael Noblet
no flags Details
output of sudo journalctl -x -n 300 prior to enabling network via nm-applet (35.70 KB, text/plain)
2013-06-03 11:13 EDT, Nathanael Noblet
no flags Details
/var/log/messages with NM Logging set to Debug (69.72 KB, text/plain)
2013-06-04 12:44 EDT, Nathanael Noblet
no flags Details
Failed resume (101.69 KB, text/plain)
2013-06-05 12:13 EDT, Nathanael Noblet
no flags Details

  None (edit)
Description Nathanael Noblet 2013-06-03 11:11:22 EDT
Created attachment 756354 [details]
the result of sudo grep NetworkManager /var/log/messages after resume but before manually enabling the network via NM Applet

Description of problem:
After I wake my desktop from sleep the internet doesn't re-connect. NM-Applet shows that it is 'off', I have to turn it on at which point it connects and works fine till the next sleep cycle.

Version-Release number of selected component (if applicable):
0.9.8.1-4.git20130515-fc19

How reproducible:
Always

Steps to Reproduce:
1. Computer with wired connection
2. Suspend machine
3. Wake

Actual results:
Internet doesn't auto-resume and is marked as 'off'

Expected results:
Internet connection resumes as well.

Additional info:
Comment 1 Nathanael Noblet 2013-06-03 11:12:12 EDT
Created attachment 756355 [details]
sudo grep NetworkManager /var/log/messages after manually enabling the network via nm-applet
Comment 2 Nathanael Noblet 2013-06-03 11:13:22 EDT
Created attachment 756356 [details]
output of sudo journalctl -x -n 300 prior to enabling network via nm-applet
Comment 3 Dan Williams 2013-06-03 11:41:36 EDT
Ok, when you wake up before you enable via nm-applet, can you run:

nmcli dev list iface eth0

and we care about the AUTOCONNECT field.  Thanks!
Comment 4 Nathanael Noblet 2013-06-03 11:43:43 EDT
GENERAL.AUTOCONNECT:                    yes


Full output:

GENERAL.DEVICE:                         eth0
GENERAL.TYPE:                           802-3-ethernet
GENERAL.VENDOR:                         Realtek Semiconductor Co., Ltd.
GENERAL.PRODUCT:                        --
GENERAL.DRIVER:                         r8169
GENERAL.DRIVER-VERSION:                 2.3LK-NAPI
GENERAL.FIRMWARE-VERSION:               
GENERAL.HWADDR:                         1C:6F:65:3C:54:1C
GENERAL.STATE:                          30 (disconnected)
GENERAL.REASON:                         40 (Carrier/link changed)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:1c.4/0000:07:00.0/net/eth0
GENERAL.IP-IFACE:                       
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.CONNECTION:                     not connected
CAPABILITIES.CARRIER-DETECT:            yes
CAPABILITIES.SPEED:                     100 Mb/s
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: /org/freedesktop/NetworkManager/Settings/{0}
CONNECTIONS.AVAILABLE-CONNECTIONS[1]:   7e804f22-a220-4829-a8b8-6e3e1aaf1df5 | eth0
WIRED-PROPERTIES.CARRIER:               on
Comment 5 Dan Williams 2013-06-03 12:41:28 EDT
Interesting; so the device is not blocked for autoconnect, but NM doesn't appear to try to autoconnect anything.  The logs aren't going to help us here since they're not detailed enough, so we'll probably need some custom builds, or I'll have to see if I can reproduce the issue.
Comment 6 Nathanael Noblet 2013-06-03 15:45:13 EDT
I should note I also just rebooted the machine and the network didn't come up in that scenario either.

I can build or install whatever to test this out... you know where I am in IRC whenever you feel like tackling this.
Comment 7 Dan Williams 2013-06-04 12:37:45 EDT
Can you do the following for me?

sudo dbus-send --system --print-reply --dest=org.freedesktop.NetworkManager /org/freedesktop/NetworkManager org.freedesktop.NetworkManager.SetLogging string:"debug" string:""

and then suspend/resume and post the syslog/journal output for NM.
Comment 8 Nathanael Noblet 2013-06-04 12:44:23 EDT
Created attachment 756884 [details]
/var/log/messages with NM Logging set to Debug

Oddly the network worked this time.
Comment 9 Dan Williams 2013-06-04 15:14:47 EDT
Ok, see if you can leave the debugging there and then paste the logs when it doesn't work.  Thanks!
Comment 10 Nathanael Noblet 2013-06-05 12:13:26 EDT
Created attachment 757271 [details]
Failed resume
Comment 11 Dan Williams 2013-06-05 13:09:09 EDT
via IRC we discovered there's /etc/NetworkManager/system-connections/Auto Ethernet which has autoconnect=no, which is causing this.  So that's one mystery down, but the next mystery is how that file got there in the first place.
Comment 12 Nathanael Noblet 2013-06-18 12:14:58 EDT
More than likely this is user called issue. So I'll close this to knock one off your list.

Note You need to log in before you can comment on or make changes to this bug.